{"answers":{"affected":"2 open source packages ship an affected version, including justhtml.","exploited":"There is no known exploitation of CVE-2026-6827 in the wild and no public exploit code.","fix":"Upgrade justhtml to 1.17.0 or later.","what":"CVE-2026-6827 is a medium-severity cross-site scripting vulnerability in EmilStenstrom justhtml, published on 23 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-6827 and fix it if it is affected.\n\nWhat it is: CVE-2026-6827 is a medium-severity cross-site scripting vulnerability in EmilStenstrom justhtml, published on 23 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-6827 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- justhtml (PyPI): affected all versions; fixed in 1.17.0\n- justhtml (PyPI): affected all versions; fixed in 1.17.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6827/ (Markdown: https://insights.sbomify.com/CVE-2026-6827/index.md)","id":"CVE-2026-6827","markdown":"https://insights.sbomify.com/CVE-2026-6827/index.md","name":"CVE-2026-6827","record":{"aliases":["GHSA-f8m6-5gph-fw7f","GHSA-vrx2-77f2-ww34"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"HTML sanitization library","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via XSS in justhtml when using custom policies that preserve foreign namespaces or specific DOM structures.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"justhtml before 1.17.0 contains multiple security issues in sanitization, serialization, and programmatic DOM handling. When custom policies preserve foreign namespaces (SVG/MathML), dangerous content such as HTML integration points (SVG \u003cforeignObject\u003e, MathML \u003cannotation-xml encoding=\"text/html\"\u003e) and mutation-XSS parser-differential payloads could survive sanitization and become active HTML after reparse; SVG filter=\"url(...)\" and preserved \u003cstyle\u003e could leave resource-loading CSS (@import, background-image:url()). Programmatic script/style/Comment nodes could serialize into active markup. Additional hardening fixes address sanitize-pipeline cache mutation and DOM parent/child cycles that could cause infinite loops. Most issues affect advanced or custom configurations rather than the default JustHTML(..., sanitize=True) safe path.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"justhtml before 1.17.0 Multiple Cross-Site Scripting Vulnerabilities","id":"CVE-2026-6827","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in Fluent Forms – Customizable Contact Forms, Survey, Quiz, \u0026 Conversational Form Builder","id":"CVE-2026-6828"},"packages":[{"ecosystem":"PyPI","fixed":["1.17.0"],"introduced":["0"],"last_affected":[],"package":"justhtml","purl":null,"source":"GHSA-vrx2-77f2-ww34"},{"ecosystem":"PyPI","fixed":["1.17.0"],"introduced":["0"],"last_affected":[],"package":"justhtml","purl":"pkg:pypi/justhtml","source":"GHSA-vrx2-77f2-ww34"}],"prev":{"headline":"Concrete 9.5.0 and below has file usage disclosure via missing permission check in Usage controller","id":"CVE-2026-6826"},"products":["justhtml"],"published":"2026-08-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-29","vendors":["EmilStenstrom"]},"summary":"Attackers can execute arbitrary scripts via XSS in justhtml when using custom policies that preserve foreign namespaces or specific DOM structures.","url":"https://insights.sbomify.com/CVE-2026-6827/"}