# CVE-2026-6827: justhtml before 1.17.0 Multiple Cross-Site Scripting Vulnerabilities

> Attackers can execute arbitrary scripts via XSS in justhtml when using custom policies that preserve foreign namespaces or specific DOM structures.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 23 Aug 2026
- **Updated:** 29 Aug 2026
- **Also known as:** GHSA-f8m6-5gph-fw7f, GHSA-vrx2-77f2-ww34

## What is CVE-2026-6827?

CVE-2026-6827 is a medium-severity cross-site scripting vulnerability in EmilStenstrom justhtml, published on 23 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

justhtml before 1.17.0 contains multiple security issues in sanitization, serialization, and programmatic DOM handling. When custom policies preserve foreign namespaces (SVG/MathML), dangerous content such as HTML integration points (SVG <foreignObject>, MathML <annotation-xml encoding="text/html">) and mutation-XSS parser-differential payloads could survive sanitization and become active HTML after reparse; SVG filter="url(...)" and preserved <style> could leave resource-loading CSS (@import, background-image:url()). Programmatic script/style/Comment nodes could serialize into active markup. Additional hardening fixes address sanitize-pipeline cache mutation and DOM parent/child cycles that could cause infinite loops. Most issues affect advanced or custom configurations rather than the default JustHTML(..., sanitize=True) safe path.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-6827?

2 open source packages ship an affected version, including justhtml.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `justhtml` | PyPI | All versions | 1.17.0 |
| `justhtml` | PyPI | All versions | 1.17.0 |

## How do I fix CVE-2026-6827?

Upgrade justhtml to 1.17.0 or later.

## Is CVE-2026-6827 being exploited?

There is no known exploitation of CVE-2026-6827 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6827 and fix it if it is affected.

What it is: CVE-2026-6827 is a medium-severity cross-site scripting vulnerability in EmilStenstrom justhtml, published on 23 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-6827 in the wild and no public exploit code.

Affected packages and fixed versions:
- justhtml (PyPI): affected all versions; fixed in 1.17.0
- justhtml (PyPI): affected all versions; fixed in 1.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6827/ (Markdown: https://insights.sbomify.com/CVE-2026-6827/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6827
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6827
- OSV: https://osv.dev/vulnerability/CVE-2026-6827

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6827/
Summaries are generated and may contain mistakes; the official description above is the record.
