CVE-2026-68497 jackson-databind: Duration XMLGregorianCalendar Unbounded Number Parse DoS

High 7.5 Published Updated

An unauthenticated attacker can cause CPU exhaustion and denial of service by sending crafted JSON payloads to applications using jackson-databind.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-68497?

CVE-2026-68497 is a high-severity denial of service vulnerability in FasterXML jackson-databind, published on 11 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

jackson-databind binds a JSON string to a javax.xml.datatype.Duration or javax.xml.datatype.XMLGregorianCalendar field by passing the raw string verbatim to DatatypeFactory.newDuration(value) or newXMLGregorianCalendar(value) in CoreXMLDeserializers.Std._deserialize. These deserializers are registered by default with no opt-in, so a plain ObjectMapper or JsonMapper with no polymorphic typing and no special configuration reaches this path. The XML Schema lexical grammar permits numeric components of arbitrary length, which the JDK materializes through the native BigInteger(String) and BigDecimal(String) constructors, both quadratic in digit count. Because the digits sit inside a JSON string token rather than a JSON number token, jackson-core's StreamReadConstraints.maxNumberLength guard never applies; jackson's own NumberDeserializers call validateIntegerLength or validateFPLength before parsing a stringified number, but the XML datatype deserializer omits that pre-check. An unauthenticated attacker can therefore submit a single request of a few megabytes, such as a Duration value consisting of the letter P followed by several million digits and the letter Y, and force tens of seconds to several minutes of single-threaded CPU work; a handful of concurrent requests can saturate a server's worker threads. This affects com.fasterxml.jackson.core:jackson-databind from 2.0.0 before 2.18.10, from 2.19.0 before 2.21.6, and from 2.22.0 before 2.22.2, and tools.jackson.core:jackson-databind from 3.0.0 before 3.1.6 and from 3.2.0 before 3.2.2. Users should upgrade to 2.18.10, 2.21.6, 2.22.2, 3.1.6, or 3.2.2.

Weakness: CWE-400, CWE-1333

Which versions are affected by CVE-2026-68497?

10 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind and tools.jackson.core:jackson-databind.

PackageAffectedFixed in
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.14.02.18.10
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.14.02.18.10
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.19.02.21.6
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.19.02.21.6
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.22.02.22.2
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.22.02.22.2
4 more packages
tools.jackson.core:jackson-databind MavenFrom 3.0.03.1.6
tools.jackson.core:jackson-databind MavenFrom 3.0.03.1.6
tools.jackson.core:jackson-databind MavenFrom 3.2.03.2.2
tools.jackson.core:jackson-databind MavenFrom 3.2.03.2.2
Linux distribution packages (30)
idm-pki-acme AlmaLinux:10All versions11.9.0-6.el10_2.alma.1
idm-pki-base AlmaLinux:10All versions11.9.0-6.el10_2.alma.1
idm-pki-ca AlmaLinux:10All versions11.9.0-6.el10_2.alma.1
idm-pki-java AlmaLinux:10All versions11.9.0-6.el10_2.alma.1
idm-pki-kra AlmaLinux:10All versions11.9.0-6.el10_2.alma.1
idm-pki-server AlmaLinux:10All versions11.9.0-6.el10_2.alma.1
idm-pki-tools AlmaLinux:10All versions11.9.0-6.el10_2.alma.1
python3-idm-pki AlmaLinux:10All versions11.9.0-6.el10_2.alma.1
pki-jackson-core AlmaLinux:9All versions2.21.6-1.el9_8
pki-jackson-databind AlmaLinux:9All versions2.21.6-1.el9_8
pki-jackson-jaxrs-json-provider AlmaLinux:9All versions2.21.6-1.el9_8
pki-jackson-jaxrs-providers AlmaLinux:9All versions2.21.6-1.el9_8
pki-jackson-module-jaxb-annotations AlmaLinux:9All versions2.21.6-1.el9_8
dogtag-pki Red Hat:enterprise_linux:10.2All versions0:11.9.0-6.el10_2
dogtag-pki-debugsource Red Hat:enterprise_linux:10.2All versions0:11.9.0-6.el10_2
idm-pki-acme Red Hat:enterprise_linux:10.2All versions0:11.9.0-6.el10_2
idm-pki-base Red Hat:enterprise_linux:10.2All versions0:11.9.0-6.el10_2
idm-pki-ca Red Hat:enterprise_linux:10.2All versions0:11.9.0-6.el10_2
idm-pki-java Red Hat:enterprise_linux:10.2All versions0:11.9.0-6.el10_2
idm-pki-kra Red Hat:enterprise_linux:10.2All versions0:11.9.0-6.el10_2
idm-pki-server Red Hat:enterprise_linux:10.2All versions0:11.9.0-6.el10_2
idm-pki-tools Red Hat:enterprise_linux:10.2All versions0:11.9.0-6.el10_2
idm-pki-tools-debuginfo Red Hat:enterprise_linux:10.2All versions0:11.9.0-6.el10_2
python3-idm-pki Red Hat:enterprise_linux:10.2All versions0:11.9.0-6.el10_2
jackson-core Red Hat:enterprise_linux:9::appstreamAll versions0:2.21.6-1.el9_8
jackson-databind Red Hat:enterprise_linux:9::appstreamAll versions0:2.21.6-1.el9_8
jackson-jaxrs-providers Red Hat:enterprise_linux:9::appstreamAll versions0:2.21.6-1.el9_8
jackson-modules-base Red Hat:enterprise_linux:9::appstreamAll versions0:2.21.6-1.el9_8
pki-jackson-core Red Hat:enterprise_linux:9::appstreamAll versions0:2.21.6-1.el9_8
pki-jackson-databind Red Hat:enterprise_linux:9::appstreamAll versions0:2.21.6-1.el9_8

How do I fix CVE-2026-68497?

Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.18.10, 2.21.6 or 2.22.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-68497 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68497 exists.

Sources

Also known as ALSA-2026:77648, ALSA-2026:80504, CLEANSTART-2026-AW63553, CLEANSTART-2026-BM41905, CLEANSTART-2026-BM99045, CLEANSTART-2026-JD77891 and 134 more.

Is CVE-2026-68497 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free