# CVE-2026-68499: re2: Global `String.prototype.match` with an empty-matchable pattern never advances → infinite loop with unbounded native memory growth (DoS)

> An attacker can cause a denial of service by triggering an infinite loop and memory exhaustion in the re2 library using specific regex patterns.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** CLEANSTART-2026-TO50877, DEBIAN-CVE-2026-68499, GHSA-6hxr-mr5r-9836, MINI-2qrf-3q8h-9c6x, UBUNTU-CVE-2026-68499

## What is CVE-2026-68499?

CVE-2026-68499 is a medium-severity denial of service vulnerability in uhop node-re2, published on 30 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

re2 provides Node.js bindings for Google's RE2 regular expression engine. Prior to 1.25.2, re2's String.prototype.match implementation with a global RE2 pattern that can match the empty string fails to advance its native matching cursor in lib/match.cc, causing an infinite loop and unbounded native memory growth that blocks the event loop and can exhaust host memory. This issue is fixed in 1.25.2.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2026-68499?

2 open source packages ship an affected version, including re2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `re2` | npm | All versions | 1.25.2 |
| `re2` | npm | All versions | 1.25.2 |

## How do I fix CVE-2026-68499?

Upgrade re2 to 1.25.2 or later.

## Is CVE-2026-68499 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68499 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68499 and fix it if it is affected.

What it is: CVE-2026-68499 is a medium-severity denial of service vulnerability in uhop node-re2, published on 30 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68499 exists.

Affected packages and fixed versions:
- re2 (npm): affected all versions; fixed in 1.25.2
- re2 (npm): affected all versions; fixed in 1.25.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68499/ (Markdown: https://insights.sbomify.com/CVE-2026-68499/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68499
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68499
- OSV: https://osv.dev/vulnerability/CVE-2026-68499

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68499/
Summaries are generated and may contain mistakes; the official description above is the record.
