CVE-2026-68500 Sylius Mollie Plugin: Payment status forgery via the payment webhook
An unauthenticated attacker can forge payment status for victim orders by exploiting missing validation in the Mollie payment webhook.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-68500?
CVE-2026-68500 is a high-severity vulnerability in Sylius MolliePlugin, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Sylius Mollie Plugin provides Mollie payment integration for Sylius applications. Prior to 2.2.8, 3.2.4, and 3.3.1, Sylius Mollie Plugin's POST /{_locale}/update-payment payment webhook accepts attacker-controlled id and orderId parameters but does not verify that the Mollie payment belongs to the referenced Sylius order, allowing an unauthenticated attacker with any valid paid Mollie payment ID to mark a victim order as paid without transferring funds for that order. This issue is fixed in 2.2.8, 3.2.4, and 3.3.1.
Weakness: CWE-639
Which versions are affected by CVE-2026-68500?
6 open source packages ship an affected version, including sylius/mollie-plugin.
| Package | Affected | Fixed in |
|---|---|---|
sylius/mollie-plugin Packagist | All versions | 2.2.8 |
sylius/mollie-plugin Packagist | All versions | 2.2.8 |
sylius/mollie-plugin Packagist | From 3.0.0 | 3.2.4 |
sylius/mollie-plugin Packagist | From 3.0.0 | 3.2.4 |
sylius/mollie-plugin Packagist | From 3.3.0 | 3.3.1 |
sylius/mollie-plugin Packagist | From 3.3.0 | 3.3.1 |
How do I fix CVE-2026-68500?
Upgrade sylius/mollie-plugin to a fixed version for your release line: 2.2.8, 3.2.4 or 3.3.1.
Is CVE-2026-68500 being exploited?
There is no known exploitation of CVE-2026-68500 in the wild and no public exploit code.
Sources
Also known as GHSA-rc52-c4hv-w89p.