# CVE-2026-68500: Sylius Mollie Plugin: Payment status forgery via the payment webhook

> An unauthenticated attacker can forge payment status for victim orders by exploiting missing validation in the Mollie payment webhook.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** GHSA-rc52-c4hv-w89p

## What is CVE-2026-68500?

CVE-2026-68500 is a high-severity vulnerability in Sylius MolliePlugin, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sylius Mollie Plugin provides Mollie payment integration for Sylius applications. Prior to 2.2.8, 3.2.4, and 3.3.1, Sylius Mollie Plugin's POST /{_locale}/update-payment payment webhook accepts attacker-controlled id and orderId parameters but does not verify that the Mollie payment belongs to the referenced Sylius order, allowing an unauthenticated attacker with any valid paid Mollie payment ID to mark a victim order as paid without transferring funds for that order. This issue is fixed in 2.2.8, 3.2.4, and 3.3.1.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-68500?

6 open source packages ship an affected version, including sylius/mollie-plugin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sylius/mollie-plugin` | Packagist | All versions | 2.2.8 |
| `sylius/mollie-plugin` | Packagist | All versions | 2.2.8 |
| `sylius/mollie-plugin` | Packagist | From 3.0.0 | 3.2.4 |
| `sylius/mollie-plugin` | Packagist | From 3.0.0 | 3.2.4 |
| `sylius/mollie-plugin` | Packagist | From 3.3.0 | 3.3.1 |
| `sylius/mollie-plugin` | Packagist | From 3.3.0 | 3.3.1 |

## How do I fix CVE-2026-68500?

Upgrade sylius/mollie-plugin to a fixed version for your release line: 2.2.8, 3.2.4 or 3.3.1.

## Is CVE-2026-68500 being exploited?

There is no known exploitation of CVE-2026-68500 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68500 and fix it if it is affected.

What it is: CVE-2026-68500 is a high-severity vulnerability in Sylius MolliePlugin, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-68500 in the wild and no public exploit code.

Affected packages and fixed versions:
- sylius/mollie-plugin (Packagist): affected all versions; fixed in 2.2.8
- sylius/mollie-plugin (Packagist): affected all versions; fixed in 2.2.8
- sylius/mollie-plugin (Packagist): affected from 3.0.0; fixed in 3.2.4
- sylius/mollie-plugin (Packagist): affected from 3.0.0; fixed in 3.2.4
- sylius/mollie-plugin (Packagist): affected from 3.3.0; fixed in 3.3.1
- sylius/mollie-plugin (Packagist): affected from 3.3.0; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68500/ (Markdown: https://insights.sbomify.com/CVE-2026-68500/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68500
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68500
- OSV: https://osv.dev/vulnerability/CVE-2026-68500

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68500/
Summaries are generated and may contain mistakes; the official description above is the record.
