# CVE-2026-68515: OpenEXR: Heap out-of-bounds write in exrmultiview with subsampled channel union

> Attacker can trigger heap out-of-bounds write in exrmultiview by providing crafted EXR files, potentially leading to code execution or crashes.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 26 Aug 2026
- **Also known as:** ALSA-2026:69608, ALSA-2026:69609, AZL-97646, BELL-CVE-2026-68515, CLSA-2026-1790780350, CLSA-2026-1790781324, DEBIAN-CVE-2026-68515, ECHO-4a45-30ec-eef0, GHSA-gjf7-wjjw-xq56, MINI-3wvr-x389-vx58, RHSA-2026:69608, RHSA-2026:69609, RLSA-2026:69608, RLSA-2026:69609, ROOT-OS-DEBIAN-11-CVE-2026-68515, ROOT-OS-DEBIAN-12-CVE-2026-68515, ROOT-OS-DEBIAN-13-CVE-2026-68515, UBUNTU-CVE-2026-68515

## What is CVE-2026-68515?

CVE-2026-68515 is a high-severity memory corruption vulnerability in AcademySoftwareFoundation openexr, published on 25 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenEXR is the reference implementation and specification for the EXR image format, widely used in the motion picture industry. In versions before 3.2.11, 3.3.0 through 3.3.12, and 3.4.0 through 3.4.13, exrmultiview can write past a heap allocation when it combines two attacker-supplied, individually valid scanline EXR files whose union dataWindow is not aligned to one view's channel subsampling. The utility allocates sampled channel storage using a truncated union_width / xSampling, then reads the sampled input through a Slice based on the misaligned union window, producing a heap out-of-bounds write. The trigger is normal public-tool processing, such as exrmultiview left A.exr right B.exr out.exr with crafted but valid inputs, so this is not solely an API or caller-precondition issue. This issue is fixed in versions 3.2.11, 3.3.13, and 3.4.14.

Weakness: CWE-787 (Out-of-bounds Write), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-68515?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openexr` | AlmaLinux:10 | All versions | 3.1.10-8.el10_2.4 |
| `openexr-devel` | AlmaLinux:10 | All versions | 3.1.10-8.el10_2.4 |
| `openexr-libs` | AlmaLinux:10 | All versions | 3.1.10-8.el10_2.4 |
| `openexr` | AlmaLinux:9 | All versions | 3.1.1-3.el9_8.4 |
| `openexr-devel` | AlmaLinux:9 | All versions | 3.1.1-3.el9_8.4 |
| `openexr-libs` | AlmaLinux:9 | All versions | 3.1.1-3.el9_8.4 |
| `openexr` | Red Hat:enterprise_linux:10.2 | All versions | 0:3.1.10-8.el10_2.4 |
| `openexr-debuginfo` | Red Hat:enterprise_linux:10.2 | All versions | 0:3.1.10-8.el10_2.4 |
| `openexr-debugsource` | Red Hat:enterprise_linux:10.2 | All versions | 0:3.1.10-8.el10_2.4 |
| `openexr-devel` | Red Hat:enterprise_linux:10.2 | All versions | 0:3.1.10-8.el10_2.4 |
| `openexr-libs` | Red Hat:enterprise_linux:10.2 | All versions | 0:3.1.10-8.el10_2.4 |
| `openexr-libs-debuginfo` | Red Hat:enterprise_linux:10.2 | All versions | 0:3.1.10-8.el10_2.4 |
| `openexr` | Red Hat:enterprise_linux:9::appstream | All versions | 0:3.1.1-3.el9_8.4 |
| `openexr-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:3.1.1-3.el9_8.4 |
| `openexr-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:3.1.1-3.el9_8.4 |
| `openexr-libs` | Red Hat:enterprise_linux:9::appstream | All versions | 0:3.1.1-3.el9_8.4 |
| `openexr-libs-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:3.1.1-3.el9_8.4 |
| `openexr-debuginfo` | Red Hat:enterprise_linux:9::crb | All versions | 0:3.1.1-3.el9_8.4 |
| `openexr-debugsource` | Red Hat:enterprise_linux:9::crb | All versions | 0:3.1.1-3.el9_8.4 |
| `openexr-devel` | Red Hat:enterprise_linux:9::crb | All versions | 0:3.1.1-3.el9_8.4 |
| `openexr-libs-debuginfo` | Red Hat:enterprise_linux:9::crb | All versions | 0:3.1.1-3.el9_8.4 |
| `openexr` | Rocky Linux:10 | All versions | 0:3.1.10-8.el10_2.4 |
| `openexr` | Rocky Linux:9 | All versions | 0:3.1.1-3.el9_8.4 |

## How do I fix CVE-2026-68515?

Upgrade to a fixed version.

## Is CVE-2026-68515 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68515 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68515 and fix it if it is affected.

What it is: CVE-2026-68515 is a high-severity memory corruption vulnerability in AcademySoftwareFoundation openexr, published on 25 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68515 exists.

Affected product: AcademySoftwareFoundation openexr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68515/ (Markdown: https://insights.sbomify.com/CVE-2026-68515/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68515
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68515
- OSV: https://osv.dev/vulnerability/CVE-2026-68515

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68515/
Summaries are generated and may contain mistakes; the official description above is the record.
