# CVE-2026-68516: OpenEXR: HTJ2K SIZ image-offset gap stack buffer overflow

> A crafted HTJ2K-compressed EXR file can cause a stack buffer overflow in OpenEXR, leading to a denial of service during image decoding.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** BELL-CVE-2026-68516, DEBIAN-CVE-2026-68516, GHSA-fw66-6xph-56jm, MINI-7x59-6w4j-44wf, UBUNTU-CVE-2026-68516

## What is CVE-2026-68516?

CVE-2026-68516 is a medium-severity memory corruption vulnerability in AcademySoftwareFoundation openexr, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenEXR is the reference implementation and specification for the EXR image format, widely used in the motion picture industry. From version 3.4.0 through 3.4.13, a crafted HTJ2K-compressed EXR can crash OpenEXR during normal decode. An HTJ2K-compressed EXR whose JPEG 2000 SIZ fields place the first tile outside the visible image can reach invalid tile and codeblock geometry in the vendored OpenJPH AVX2 decoder, causing a stack out-of-bounds write and denial of service. OpenEXR's HTJ2K path validates the decoded codestream dimensions against the EXR chunk size, but it does not reject SIZ image-offset/tile-grid geometry where the first tile does not intersect the image. This issue is fixed in version 3.4.14.

Weakness: CWE-787 (Out-of-bounds Write), CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2026-68516?


## How do I fix CVE-2026-68516?

Upgrade to a fixed version.

## Is CVE-2026-68516 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68516 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68516 and fix it if it is affected.

What it is: CVE-2026-68516 is a medium-severity memory corruption vulnerability in AcademySoftwareFoundation openexr, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68516 exists.

Affected product: AcademySoftwareFoundation openexr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68516/ (Markdown: https://insights.sbomify.com/CVE-2026-68516/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68516
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68516
- OSV: https://osv.dev/vulnerability/CVE-2026-68516

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68516/
Summaries are generated and may contain mistakes; the official description above is the record.
