{"answers":{"affected":"3 open source packages ship an affected version, including glances.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68517 exists.","fix":"Upgrade glances to 4.5.6 or later.","what":"CVE-2026-68517 is a medium-severity vulnerability in nicolargo glances, published on 17 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-68517 and fix it if it is affected.\n\nWhat it is: CVE-2026-68517 is a medium-severity vulnerability in nicolargo glances, published on 17 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68517 exists.\n\nAffected packages and fixed versions:\n- glances (PyPI): affected all versions; fixed in 4.5.6\n- glances (PyPI): affected all versions; fixed in 4.5.6\n- glances (PyPI): affected all versions; fixed in 4.5.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-68517/ (Markdown: https://insights.sbomify.com/CVE-2026-68517/index.md)","id":"CVE-2026-68517","markdown":"https://insights.sbomify.com/CVE-2026-68517/index.md","name":"CVE-2026-68517","record":{"aliases":["DEBIAN-CVE-2026-68517","GHSA-fp27-88fp-2phg","PYSEC-2026-3667","UBUNTU-CVE-2026-68517"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"System monitoring tool","requires_auth":"none","summary":"Attackers can bypass CORS restrictions to read authenticated data from Glances REST API if a wildcard is in the allowlist.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-942","name":"Permissive Cross-domain Security Policy with Untrusted Domains"}],"description":"Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.6, the cors_origins guard in glances/outputs/glances_restful_api.py uses exact list equality instead of wildcard membership, allowing a multi-origin list containing the wildcard to retain cors_credentials and expose authenticated REST API data to an untrusted website visited by a previously authenticated user. This issue is fixed in 4.5.6.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Glances: REST API CORS Credentials Guard Uses Exact-Match Instead of Membership Test — Bypassed by Any Multi-Origin Allowlist Containing the Wildcard","id":"CVE-2026-68517","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Glances: Command injection bypass of action-template sanitizer via cross-field shell-operator reconstruction","id":"CVE-2026-68518"},"packages":[{"ecosystem":"PyPI","fixed":["4.5.6"],"introduced":["0"],"last_affected":[],"package":"glances","purl":null,"source":"GHSA-fp27-88fp-2phg"},{"ecosystem":"PyPI","fixed":["4.5.6"],"introduced":["0"],"last_affected":[],"package":"glances","purl":"pkg:pypi/glances","source":"GHSA-fp27-88fp-2phg"},{"ecosystem":"PyPI","fixed":["4.5.6"],"introduced":["0"],"last_affected":[],"package":"glances","purl":"pkg:pypi/glances","source":"PYSEC-2026-3667"}],"prev":{"headline":"OpenEXR: HTJ2K SIZ image-offset gap stack buffer overflow","id":"CVE-2026-68516"},"products":["glances"],"published":"2026-08-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-18","vendors":["nicolargo"]},"summary":"Attackers can bypass CORS restrictions to read authenticated data from Glances REST API if a wildcard is in the allowlist.","url":"https://insights.sbomify.com/CVE-2026-68517/"}