# CVE-2026-68517: Glances: REST API CORS Credentials Guard Uses Exact-Match Instead of Membership Test — Bypassed by Any Multi-Origin Allowlist Containing the Wildcard

> Attackers can bypass CORS restrictions to read authenticated data from Glances REST API if a wildcard is in the allowlist.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-68517, GHSA-fp27-88fp-2phg, PYSEC-2026-3667, UBUNTU-CVE-2026-68517

## What is CVE-2026-68517?

CVE-2026-68517 is a medium-severity vulnerability in nicolargo glances, published on 17 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.6, the cors_origins guard in glances/outputs/glances_restful_api.py uses exact list equality instead of wildcard membership, allowing a multi-origin list containing the wildcard to retain cors_credentials and expose authenticated REST API data to an untrusted website visited by a previously authenticated user. This issue is fixed in 4.5.6.

Weakness: CWE-942 (Permissive Cross-domain Security Policy with Untrusted Domains)

## Which versions are affected by CVE-2026-68517?

3 open source packages ship an affected version, including glances.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glances` | PyPI | All versions | 4.5.6 |
| `glances` | PyPI | All versions | 4.5.6 |
| `glances` | PyPI | All versions | 4.5.6 |

## How do I fix CVE-2026-68517?

Upgrade glances to 4.5.6 or later.

## Is CVE-2026-68517 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68517 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68517 and fix it if it is affected.

What it is: CVE-2026-68517 is a medium-severity vulnerability in nicolargo glances, published on 17 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68517 exists.

Affected packages and fixed versions:
- glances (PyPI): affected all versions; fixed in 4.5.6
- glances (PyPI): affected all versions; fixed in 4.5.6
- glances (PyPI): affected all versions; fixed in 4.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68517/ (Markdown: https://insights.sbomify.com/CVE-2026-68517/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68517
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68517
- OSV: https://osv.dev/vulnerability/CVE-2026-68517

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68517/
Summaries are generated and may contain mistakes; the official description above is the record.
