# CVE-2026-68518: Glances: Command injection bypass of action-template sanitizer via cross-field shell-operator reconstruction

> Attackers can execute arbitrary commands by bypassing sanitizers in action templates when rendering attacker-controlled process fields.

- **Severity:** High 8.8 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-68518, GHSA-qcpp-8x79-hhp3, PYSEC-2026-3668, UBUNTU-CVE-2026-68518

## What is CVE-2026-68518?

CVE-2026-68518 is a high-severity command injection vulnerability in nicolargo glances, published on 17 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.6, _sanitize_mustache_dict() in glances/actions.py sanitizes individual Mustache values before chevron.render(), allowing adjacent unescaped Mustache variables to reconstruct shell operators that secure_popen() executes when attacker-controlled process or container fields are rendered by an administrator-configured action template. This issue is fixed in 4.5.6.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-68518?

3 open source packages ship an affected version, including glances.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glances` | PyPI | All versions | 4.5.6 |
| `glances` | PyPI | All versions | 4.5.6 |
| `glances` | PyPI | All versions | 4.5.6 |

## How do I fix CVE-2026-68518?

Upgrade glances to 4.5.6 or later.

## Is CVE-2026-68518 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68518 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68518 and fix it if it is affected.

What it is: CVE-2026-68518 is a high-severity command injection vulnerability in nicolargo glances, published on 17 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68518 exists.

Affected packages and fixed versions:
- glances (PyPI): affected all versions; fixed in 4.5.6
- glances (PyPI): affected all versions; fixed in 4.5.6
- glances (PyPI): affected all versions; fixed in 4.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68518/ (Markdown: https://insights.sbomify.com/CVE-2026-68518/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68518
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68518
- OSV: https://osv.dev/vulnerability/CVE-2026-68518

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68518/
Summaries are generated and may contain mistakes; the official description above is the record.
