{"answers":{"affected":"3 open source packages ship an affected version, including glances.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68520 exists.","fix":"Upgrade glances to 4.5.6 or later.","what":"CVE-2026-68520 is a medium-severity vulnerability in nicolargo glances, published on 17 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-68520 and fix it if it is affected.\n\nWhat it is: CVE-2026-68520 is a medium-severity vulnerability in nicolargo glances, published on 17 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68520 exists.\n\nAffected packages and fixed versions:\n- glances (PyPI): affected all versions; fixed in 4.5.6\n- glances (PyPI): affected all versions; fixed in 4.5.6\n- glances (PyPI): affected all versions; fixed in 4.5.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-68520/ (Markdown: https://insights.sbomify.com/CVE-2026-68520/index.md)","id":"CVE-2026-68520","markdown":"https://insights.sbomify.com/CVE-2026-68520/index.md","name":"CVE-2026-68520","record":{"aliases":["DEBIAN-CVE-2026-68520","GHSA-4h34-v6r8-mmjc","PYSEC-2026-3664","UBUNTU-CVE-2026-68520"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"System monitoring tool","requires_auth":"none","summary":"Unauthenticated attackers can retrieve sensitive credentials from API endpoints due to insufficient sanitization in Glances configuration exports.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.6, as_dict_secure() in glances/config.py checks only option names and exposes public_username and credentials embedded in public_api values through unauthenticated GET /api/4/config and GET /api/4/config/ip requests. This issue is fixed in 4.5.6.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Glances: as_dict_secure() Value-Level Bypass Leaks Credentials in URL Values via /api/4/config","id":"CVE-2026-68520","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Fulgur: Unbounded page slicing from attacker-controlled CSS height causes denial of service","id":"CVE-2026-68523"},"packages":[{"ecosystem":"PyPI","fixed":["4.5.6"],"introduced":["0"],"last_affected":[],"package":"glances","purl":null,"source":"GHSA-4h34-v6r8-mmjc"},{"ecosystem":"PyPI","fixed":["4.5.6"],"introduced":["0"],"last_affected":[],"package":"glances","purl":"pkg:pypi/glances","source":"GHSA-4h34-v6r8-mmjc"},{"ecosystem":"PyPI","fixed":["4.5.6"],"introduced":["0"],"last_affected":[],"package":"glances","purl":"pkg:pypi/glances","source":"PYSEC-2026-3664"}],"prev":{"headline":"Glances: `--disable-config-exec` does not cover on-alert action commands (incomplete fix of CVE-2026-53925)","id":"CVE-2026-68519"},"products":["glances"],"published":"2026-08-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-17","vendors":["nicolargo"]},"summary":"Unauthenticated attackers can retrieve sensitive credentials from API endpoints due to insufficient sanitization in Glances configuration exports.","url":"https://insights.sbomify.com/CVE-2026-68520/"}