CVE-2026-68537 Fulgur: Unbounded page slicing from attacker-controlled CSS height causes denial of service
An attacker can cause a denial of service in the fulgur library by supplying HTML with excessive CSS height values, leading to unbounded page slicing.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-68537?
CVE-2026-68537 is a high-severity denial of service vulnerability in fulgur-rs fulgur, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
`fulgur` converts untrusted HTML/CSS into PDF, commonly on a server that processes input supplied by many tenants. In versions prior to 0.19.0, a body-direct child whose CSS-resolved height greatly exceeds the page height was sliced into one fragment per page with no upper bound. This is fixed in version 0.19.0. A `MAX_PAGES` cap bounds the slice loop — halting it even for a `+inf` height — and non-finite layout heights are sanitized so they can no longer drive the loop. As a workaround, validate or constrain untrusted CSS (in particular `height` / `vh` on body-level elements) before passing HTML to fulgur.
Which versions are affected by CVE-2026-68537?
3 open source packages ship an affected version, including fulgur.
| Package | Affected | Fixed in |
|---|---|---|
fulgur crates.io | All versions | 0.26.0 |
fulgur crates.io | All versions | 0.26.0 |
fulgur crates.io | From 0.0.0-0 | 0.26.0 |
How do I fix CVE-2026-68537?
Upgrade fulgur to 0.26.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-68537 being exploited?
There is no known exploitation of CVE-2026-68537 in the wild and no public exploit code.
Sources
Also known as GHSA-4rf6-qx84-q9fv, RUSTSEC-2026-0201.