{"answers":{"affected":"3 open source packages ship an affected version, including fulgur.","exploited":"There is no known exploitation of CVE-2026-68537 in the wild and no public exploit code.","fix":"Upgrade fulgur to 0.26.0 or later.","what":"CVE-2026-68537 is a high-severity denial of service vulnerability in fulgur-rs fulgur, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-68537 and fix it if it is affected.\n\nWhat it is: CVE-2026-68537 is a high-severity denial of service vulnerability in fulgur-rs fulgur, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-68537 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fulgur (crates.io): affected all versions; fixed in 0.26.0\n- fulgur (crates.io): affected all versions; fixed in 0.26.0\n- fulgur (crates.io): affected from 0.0.0-0; fixed in 0.26.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-68537/ (Markdown: https://insights.sbomify.com/CVE-2026-68537/index.md)","id":"CVE-2026-68537","markdown":"https://insights.sbomify.com/CVE-2026-68537/index.md","name":"CVE-2026-68537","record":{"aliases":["GHSA-4rf6-qx84-q9fv","RUSTSEC-2026-0201"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust HTML to PDF library","requires_auth":"none","summary":"An attacker can cause a denial of service in the fulgur library by supplying HTML with excessive CSS height values, leading to unbounded page slicing.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"`fulgur` converts untrusted HTML/CSS into PDF, commonly on a server that processes input supplied by many tenants. In versions prior to 0.19.0, a body-direct child whose CSS-resolved height greatly exceeds the page height was sliced into one fragment per page with no upper bound. This is fixed in version 0.19.0. A `MAX_PAGES` cap bounds the slice loop — halting it even for a `+inf` height — and non-finite layout heights are sanitized so they can no longer drive the loop. As a workaround, validate or constrain untrusted CSS (in particular `height` / `vh` on body-level elements) before passing HTML to fulgur.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Fulgur: Unbounded page slicing from attacker-controlled CSS height causes denial of service","id":"CVE-2026-68537","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Coturn: uint16_t truncation overflow in STUN message length causes TCP stream framing bypass","id":"CVE-2026-68552"},"packages":[{"ecosystem":"crates.io","fixed":["0.26.0"],"introduced":["0"],"last_affected":[],"package":"fulgur","purl":null,"source":"GHSA-4rf6-qx84-q9fv"},{"ecosystem":"crates.io","fixed":["0.26.0"],"introduced":["0"],"last_affected":[],"package":"fulgur","purl":"pkg:cargo/fulgur","source":"GHSA-4rf6-qx84-q9fv"},{"ecosystem":"crates.io","fixed":["0.26.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"fulgur","purl":"pkg:cargo/fulgur","source":"RUSTSEC-2026-0201"}],"prev":{"headline":"Apache MyFaces: Server-Side Request Forgery / Local File Inclusion Vulnerability","id":"CVE-2026-68536"},"products":["fulgur"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["fulgur-rs"]},"summary":"An attacker can cause a denial of service in the fulgur library by supplying HTML with excessive CSS height values, leading to unbounded page slicing.","url":"https://insights.sbomify.com/CVE-2026-68537/"}