# CVE-2026-68537: Fulgur: Unbounded page slicing from attacker-controlled CSS height causes denial of service

> An attacker can cause a denial of service in the fulgur library by supplying HTML with excessive CSS height values, leading to unbounded page slicing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-4rf6-qx84-q9fv, RUSTSEC-2026-0201

## What is CVE-2026-68537?

CVE-2026-68537 is a high-severity denial of service vulnerability in fulgur-rs fulgur, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

`fulgur` converts untrusted HTML/CSS into PDF, commonly on a server that processes input supplied by many tenants. In versions prior to 0.19.0, a body-direct child whose CSS-resolved height greatly exceeds the page height was sliced into one fragment per page with no upper bound. This is fixed in version 0.19.0. A `MAX_PAGES` cap bounds the slice loop — halting it even for a `+inf` height — and non-finite layout heights are sanitized so they can no longer drive the loop. As a workaround, validate or constrain untrusted CSS (in particular `height` / `vh` on body-level elements) before passing HTML to fulgur.

Weakness: CWE-835 (Loop with Unreachable Exit Condition), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-68537?

3 open source packages ship an affected version, including fulgur.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fulgur` | crates.io | All versions | 0.26.0 |
| `fulgur` | crates.io | All versions | 0.26.0 |
| `fulgur` | crates.io | From 0.0.0-0 | 0.26.0 |

## How do I fix CVE-2026-68537?

Upgrade fulgur to 0.26.0 or later.

## Is CVE-2026-68537 being exploited?

There is no known exploitation of CVE-2026-68537 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68537 and fix it if it is affected.

What it is: CVE-2026-68537 is a high-severity denial of service vulnerability in fulgur-rs fulgur, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-68537 in the wild and no public exploit code.

Affected packages and fixed versions:
- fulgur (crates.io): affected all versions; fixed in 0.26.0
- fulgur (crates.io): affected all versions; fixed in 0.26.0
- fulgur (crates.io): affected from 0.0.0-0; fixed in 0.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68537/ (Markdown: https://insights.sbomify.com/CVE-2026-68537/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68537
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68537
- OSV: https://osv.dev/vulnerability/CVE-2026-68537

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68537/
Summaries are generated and may contain mistakes; the official description above is the record.
