# CVE-2026-68569: Apache Tomcat: Principal lookup can fail open in some cases

> Attackers can bypass authentication in Apache Tomcat when using specific realms like DataSourceRealm with CLIENT-CERT or SPNEGO, allowing unauthorized access.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 21 Sep 2026
- **Also known as:** BIT-tomcat-2026-68569, CLSA-2026-1792400805, DEBIAN-CVE-2026-68569, GHSA-5q6q-ffrq-6xfc, MINI-m737-8xww-xhpx, MINI-q3c5-q55p-fqgv, MINI-rgqg-w2g7-4vwg, UBUNTU-CVE-2026-68569

## What is CVE-2026-68569?

CVE-2026-68569 is a high-severity authentication bypass vulnerability in Apache Tomcat, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Authentication vulnerability in Apache Tomcat meant that in some circumstances (e.g. CLIENT-CERT, SPNEGO) that a user would be authenticated even if the user did not exist in the DataSourceRealm.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120.

The following versions were EOL at the time the CVE was created but are 
known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected.

Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-68569?

1 open source package ship an affected version, including tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tomcat` | Bitnami | All versions | 9.0.121, 10.1.58, 11.0.25 |

Products: Apache Tomcat.

## How do I fix CVE-2026-68569?

Upgrade tomcat to a fixed version for your release line: 9.0.121, 10.1.58 or 11.0.25.

## Is CVE-2026-68569 being exploited?

There is no known exploitation of CVE-2026-68569 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68569 and fix it if it is affected.

What it is: CVE-2026-68569 is a high-severity authentication bypass vulnerability in Apache Tomcat, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-68569 in the wild and no public exploit code.

Affected packages and fixed versions:
- tomcat (Bitnami): affected all versions; fixed in 9.0.121, 10.1.58, 11.0.25

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68569/ (Markdown: https://insights.sbomify.com/CVE-2026-68569/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68569
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68569
- OSV: https://osv.dev/vulnerability/CVE-2026-68569

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68569/
Summaries are generated and may contain mistakes; the official description above is the record.
