# CVE-2026-6857: Camel-infinispan: camel-infinispan: remote code execution via unsafe deserialization

> A remote attacker can achieve arbitrary code execution and full system control via unsafe deserialization in the ProtoStream remote aggregation repository.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2026
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-xfxp-ppx7-cqrp

## What is CVE-2026-6857?

CVE-2026-6857 is a high-severity unsafe deserialization vulnerability in Red Hat Build of Apache Camel 4.18 for Quarkus 3.33, published on 22 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in camel-infinispan. This vulnerability involves unsafe deserialization in the ProtoStream remote aggregation repository. A remote attacker with low privileges could exploit this by sending specially crafted data, leading to arbitrary code execution. This allows the attacker to gain full control over the affected system, impacting its confidentiality, integrity, and availability.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-6857?

2 open source packages ship an affected version, including org.apache.camel:camel-infinispan.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-infinispan` | Maven | All versions | 4.20.0 |
| `org.apache.camel:camel-infinispan` | Maven | All versions | 4.20.0 |

## How do I fix CVE-2026-6857?

Upgrade org.apache.camel:camel-infinispan to 4.20.0 or later.

## Is CVE-2026-6857 being exploited?

There is no known exploitation of CVE-2026-6857 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-6857 (github_poc): https://github.com/HORKimhab/CVE-2026-6857

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6857 and fix it if it is affected.

What it is: CVE-2026-6857 is a high-severity unsafe deserialization vulnerability in Red Hat Build of Apache Camel 4.18 for Quarkus 3.33, published on 22 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6857 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-infinispan (Maven): affected all versions; fixed in 4.20.0
- org.apache.camel:camel-infinispan (Maven): affected all versions; fixed in 4.20.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6857/ (Markdown: https://insights.sbomify.com/CVE-2026-6857/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6857
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6857
- OSV: https://osv.dev/vulnerability/CVE-2026-6857

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6857/
Summaries are generated and may contain mistakes; the official description above is the record.
