CVE-2026-68570 Apache Doris: Authorization bypass leading to unauthorized data access

Medium 6.5 Published Updated

Authenticated users can bypass privilege checks to access unauthorized data in Apache Doris, requiring an upgrade to fixed versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-68570?

CVE-2026-68570 is a medium-severity missing authorization vulnerability in Apache Doris, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Incorrect Authorization vulnerability in Apache Doris allows an authenticated user to bypass privilege checks and access data they are not authorized to read, resulting in unauthorized disclosure of information.

This issue affects Apache Doris: from 2.0.0 through 2.1.*, from 3.0.0 through 3.0.*, from 4.0.0 before 4.0.8, and from 4.1.0 before 4.1.4.

Users are recommended to upgrade to a fixed release (4.0.8 or 4.1.4), which fixes the issue.

Weakness: CWE-863

Which versions are affected by CVE-2026-68570?

How do I fix CVE-2026-68570?

No fix has been published for CVE-2026-68570 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-68570 being exploited?

There is no known exploitation of CVE-2026-68570 in the wild and no public exploit code.

Sources

Also known as GHSA-r72p-xj9g-6pqm.

Is CVE-2026-68570 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free