# CVE-2026-68570: Apache Doris: Authorization bypass leading to unauthorized data access

> Authenticated users can bypass privilege checks to access unauthorized data in Apache Doris, requiring an upgrade to fixed versions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-r72p-xj9g-6pqm

## What is CVE-2026-68570?

CVE-2026-68570 is a medium-severity missing authorization vulnerability in Apache Doris, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incorrect Authorization vulnerability in Apache Doris allows an authenticated user to bypass privilege checks and access data they are not authorized to read, resulting in unauthorized disclosure of information.

This issue affects Apache Doris: from 2.0.0 through 2.1.*, from 3.0.0 through 3.0.*, from 4.0.0 before 4.0.8, and from 4.1.0 before 4.1.4.

Users are recommended to upgrade to a fixed release (4.0.8 or 4.1.4), which fixes the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-68570?


## How do I fix CVE-2026-68570?

No fix has been published for CVE-2026-68570 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-68570 being exploited?

There is no known exploitation of CVE-2026-68570 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68570 and fix it if it is affected.

What it is: CVE-2026-68570 is a medium-severity missing authorization vulnerability in Apache Doris, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-68570 in the wild and no public exploit code.

Affected product: Apache Doris. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68570/ (Markdown: https://insights.sbomify.com/CVE-2026-68570/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68570
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68570
- OSV: https://osv.dev/vulnerability/CVE-2026-68570

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68570/
Summaries are generated and may contain mistakes; the official description above is the record.
