# CVE-2026-6860: Vert.x has a DoS via unbounded server-side SNI SslContext cache growth

> Attackers can bypass TLS hostname verification by using wildcard certificates, allowing man-in-the-middle attacks against Eclipse Vert.x applications.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2026
- **Updated:** 12 May 2026
- **Also known as:** CLEANSTART-2026-EB50252, CLEANSTART-2026-FU49566, CLEANSTART-2026-TN22845, ECHO-0737-9682-1591, GHSA-3g76-f9xq-8vp6, MINI-2p7r-cmfx-3pqm, MINI-3q47-gq3m-m88h, MINI-47vh-gvm3-w9jv, MINI-4c62-w34f-m64w, MINI-4rvr-8rgj-666g, MINI-65jf-76qw-5vh2, MINI-7485-4mpv-fcgg, MINI-8m5r-hxvp-jxxv, MINI-8mjp-r4p9-72jx, MINI-8w68-45vv-x6vr, MINI-9j37-jcj6-qf33, MINI-9v6q-w927-573f, MINI-c8gj-5gq2-vgmp, MINI-fhfc-85rp-wr9g, MINI-g446-6v8x-4cvv, MINI-jcqm-v975-4fw2, MINI-jqjh-9p64-xvr9, MINI-m9rh-22qg-v8j4, MINI-pgw9-j6hh-93c9, MINI-pq85-fx4g-fvvc, MINI-pr4j-wfpc-3mr4, MINI-q5fh-x23j-5vc8, MINI-rjwx-67w8-2xx8, MINI-rp8v-hq34-ccjr, MINI-v5w5-238j-pcxw, MINI-v9q6-g4m6-m7g5, MINI-wwx9-w6f2-jrrh, MINI-xr87-v42g-4m6f

## What is CVE-2026-6860?

CVE-2026-6860 is a medium-severity vulnerability in Eclipse Vert.x, published on 6 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A TCP client can perform a TLS handshake and present the server name extension with a server name that is accepted by a server wildcard name, e.g. if the server is configured with a certificate accepting *.example.com, any XYZ.example.com where xyz is a valid name can be used.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-6860?

8 open source packages ship an affected version, including io.vertx:vertx-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.vertx:vertx-core` | Maven | From 4.3.4 to 4.3.8 | None |
| `io.vertx:vertx-core` | Maven | From 4.3.4 to 4.3.8 | None |
| `io.vertx:vertx-core` | Maven | From 4.4.0 to 4.4.9 | None |
| `io.vertx:vertx-core` | Maven | From 4.4.0 to 4.4.9 | None |
| `io.vertx:vertx-core` | Maven | From 4.5.0 | 4.5.27 |
| `io.vertx:vertx-core` | Maven | From 4.5.0 | 4.5.27 |
| `io.vertx:vertx-core` | Maven | From 5.0.0 | 5.0.12 |
| `io.vertx:vertx-core` | Maven | From 5.0.0 | 5.0.12 |

Products: Eclipse Vert.x.

## How do I fix CVE-2026-6860?

Upgrade io.vertx:vertx-core to a fixed version for your release line: 4.5.27 or 5.0.12.

## Is CVE-2026-6860 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6860 exists.

## Other vulnerabilities in Eclipse Vert.x

- [CVE-2019-17640](https://insights.sbomify.com/CVE-2019-17640/): Path Traversal in Eclipse Vert (critical 9.8)
- [CVE-2018-12542](https://insights.sbomify.com/CVE-2018-12542/): Eclipse Vert.x does not properly neutralize '' (forward slashes) sequences that can resolve to an external location (critical 9.8)
- [CVE-2018-12544](https://insights.sbomify.com/CVE-2018-12544/): Moderate severity vulnerability that affects io.vertx:vertx-core (critical 9.8)
- [CVE-2026-102469](https://insights.sbomify.com/CVE-2026-102469/): Deserialization in Eclipse Vert.x (critical 9.2)
- [CVE-2018-12540](https://insights.sbomify.com/CVE-2018-12540/): High severity vulnerability that affects io.vertx:vertx-web (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6860 and fix it if it is affected.

What it is: CVE-2026-6860 is a medium-severity vulnerability in Eclipse Vert.x, published on 6 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6860 exists.

Affected packages and fixed versions:
- io.vertx:vertx-core (Maven): affected from 4.3.4 up to 4.3.8; no fix listed
- io.vertx:vertx-core (Maven): affected from 4.3.4 up to 4.3.8; no fix listed
- io.vertx:vertx-core (Maven): affected from 4.4.0 up to 4.4.9; no fix listed
- io.vertx:vertx-core (Maven): affected from 4.4.0 up to 4.4.9; no fix listed
- io.vertx:vertx-core (Maven): affected from 4.5.0; fixed in 4.5.27
- io.vertx:vertx-core (Maven): affected from 4.5.0; fixed in 4.5.27
- io.vertx:vertx-core (Maven): affected from 5.0.0; fixed in 5.0.12
- io.vertx:vertx-core (Maven): affected from 5.0.0; fixed in 5.0.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6860/ (Markdown: https://insights.sbomify.com/CVE-2026-6860/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6860
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6860
- OSV: https://osv.dev/vulnerability/CVE-2026-6860

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6860/
Summaries are generated and may contain mistakes; the official description above is the record.
