# CVE-2026-68750: Quadratic sibling re-flattening in the html_sanitize_ex traversal engine allows CPU-exhaustion denial of service

> An unauthenticated attacker can cause CPU exhaustion and denial of service by submitting HTML with many sibling elements to the html_sanitize_ex library.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** EEF-CVE-2026-68750, GHSA-463q-p2fr-mh9p, GHSA-684p-mhw3-3cwq

## What is CVE-2026-68750?

CVE-2026-68750 is a high-severity denial of service vulnerability in rrrene html_sanitize_ex, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Inefficient Algorithmic Complexity vulnerability in the traversal engine in rrrene html_sanitize_ex allows an unauthenticated remote attacker to exhaust server CPU and memory via a flat run of sibling elements in sanitized HTML. The list clause of HtmlSanitizeEx.Traverser.traverse/2 recurses on the tail of a sibling list and then evaluates List.flatten([head] ++ tail) over the already flattened result, so every one of n siblings copies and re-walks the entire remaining tail. The flattening is only needed for the rare case where scrub returns several replacement nodes for one node, but the cost is paid across the whole tail at every step, making traversal quadratic in sibling count.

The traverser sits on every public entry point, so no particular scrubber or configuration is required and the payload needs only allowed tags. A 160 KB body of 20,000 sibling elements occupies a scheduler for roughly 1.7 seconds, and the cost grows faster than the body does.

This issue affects html_sanitize_ex: from 0.3.1 before 1.4.5 and from 1.5.0-rc.0 before 1.5.3.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2026-68750?

1 open source package ship an affected version, including html_sanitize_ex. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `html_sanitize_ex` | Hex | From 0.3.1 | 1.4.5, 1.5.3 |

Products: Rrrene Htmlsanitizeex.

## How do I fix CVE-2026-68750?

Upgrade html_sanitize_ex to a fixed version for your release line: 1.4.5 or 1.5.3.

## Is CVE-2026-68750 being exploited?

There is no known exploitation of CVE-2026-68750 in the wild and no public exploit code.

## Other vulnerabilities in rrrene html_sanitize_ex

- [CVE-2026-68749](https://insights.sbomify.com/CVE-2026-68749/): Quadratic regex backtracking in the html_sanitize_ex CSS scrubber allows CPU-exhaustion denial of service (high 8.2)
- [CVE-2026-66370](https://insights.sbomify.com/CVE-2026-66370/): html_sanitize_ex HTML5 scrubber keeps attacker-supplied form-association attributes, allowing form hijacking (medium 4.8)
- [CVE-2026-66829](https://insights.sbomify.com/CVE-2026-66829/): html_sanitize_ex HTML5 scrubber keeps attacker-supplied meta refresh, allowing forced cross-origin redirection (low 2.3)
- [CVE-2026-66843](https://insights.sbomify.com/CVE-2026-66843/): html_sanitize_ex HTML5 scrubber keeps attacker-supplied `<object>` elements, allowing untrusted content embedding (low 2.3)
- [CVE-2026-68747](https://insights.sbomify.com/CVE-2026-68747/): CSS sanitizer allowlist bypass in html_sanitize_ex via non-declaration input (low 2.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68750 and fix it if it is affected.

What it is: CVE-2026-68750 is a high-severity denial of service vulnerability in rrrene html_sanitize_ex, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-68750 in the wild and no public exploit code.

Affected packages and fixed versions:
- html_sanitize_ex (Hex): affected from 0.3.1; fixed in 1.4.5, 1.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68750/ (Markdown: https://insights.sbomify.com/CVE-2026-68750/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68750
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68750
- OSV: https://osv.dev/vulnerability/CVE-2026-68750

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68750/
Summaries are generated and may contain mistakes; the official description above is the record.
