CVE-2026-6883 Missing Authorization in GitLab

Low 2.6 Published Updated

Authenticated users can bypass merge request approval requirements due to improper cleanup of orphaned policy records in GitLab EE.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-6883?

CVE-2026-6883 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 14 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 15.7 before 18.9.7, 18.10 before 18.10.6, and 18.11 before 18.11.3 that could have allowed an authenticated user to bypass merge request approval requirements due to improper cleanup of orphaned policy records.

Weakness: CWE-862

Which versions are affected by CVE-2026-6883?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.7.018.9.7, 18.10.6, 18.11.3

Products include Gitlab Gitlab.

How do I fix CVE-2026-6883?

Upgrade gitlab to a fixed version for your release line: 18.9.7, 18.10.6 or 18.11.3.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-6883 being exploited?

There is no known exploitation of CVE-2026-6883 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-6883, GHSA-j7c9-9cr2-9pq2, UBUNTU-CVE-2026-6883.

Is CVE-2026-6883 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free