# CVE-2026-68868: Missing authorization in Apache Airflow Google provider

> Attackers in multi-team Airflow deployments can access other teams' credentials due to missing team scope enforcement in the Google Secret Manager backend.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-qfr4-ppjq-9gr3, PYSEC-2026-3714

## What is CVE-2026-68868?

CVE-2026-68868 is a medium-severity missing authorization vulnerability in Apache Airflow Google provider, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Google Cloud Secret Manager secrets backend in Apache Airflow's Google provider never applied the team scope when resolving Connections and Variables: the caller's `team_name` was accepted by the backend but dropped at the internal call boundary, so every lookup resolved against the team-agnostic secret name. In a deployment running multi-team mode with this backend, a task or Dag belonging to one team resolved another team's Connection or Variable, obtaining its credentials in full. No unusual configuration is required beyond enabling multi-team mode and using this backend. Users are advised to upgrade to apache-airflow-providers-google 22.3.0 or later, which builds and applies the team-scoped secret name.

Weakness: CWE-1220 (Insufficient Granularity of Access Control)

## Which versions are affected by CVE-2026-68868?

1 open source package ship an affected version, including apache-airflow-providers-google. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-google` | PyPI | All versions | 22.3.0 |

Products: Apache Apache-Airflow-Providers-Google.

## How do I fix CVE-2026-68868?

Upgrade apache-airflow-providers-google to 22.3.0 or later.

## Is CVE-2026-68868 being exploited?

There is no known exploitation of CVE-2026-68868 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow Google provider

- [CVE-2023-25691](https://insights.sbomify.com/CVE-2023-25691/): Apache Airflow Google Provider: Google Cloud Sql Provider Remote Command Execution (critical 9.8)
- [CVE-2026-49297](https://insights.sbomify.com/CVE-2026-49297/): Apache Airflow Google provider allows path traversal through GCS object names (high 8.1)
- [CVE-2026-45361](https://insights.sbomify.com/CVE-2026-45361/): Apache Airflow providers-google's `ComputeEngineSSHHook` disables SSH host-key verification by default (high 8.1)
- [CVE-2023-25692](https://insights.sbomify.com/CVE-2023-25692/): Apache Airflow Google Provider: Google Cloud Sql Provider Denial Of Service (high 7.5)
- [CVE-2026-81914](https://insights.sbomify.com/CVE-2026-81914/): Apache Airflow Google provider: Google Drive query injection via unescaped file and folder names (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68868 and fix it if it is affected.

What it is: CVE-2026-68868 is a medium-severity missing authorization vulnerability in Apache Airflow Google provider, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-68868 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-google (PyPI): affected all versions; fixed in 22.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68868/ (Markdown: https://insights.sbomify.com/CVE-2026-68868/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68868
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68868
- OSV: https://osv.dev/vulnerability/CVE-2026-68868

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68868/
Summaries are generated and may contain mistakes; the official description above is the record.
