# CVE-2026-68871: Apache Airflow Yandex Lockbox backend allows cross-team secret disclosure

> Attackers in multi-team deployments can bypass team-scope guards to read secrets belonging to other teams via the Yandex Lockbox backend.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Aug 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-qmrf-jrpr-rjx6, PYSEC-2026-3715

## What is CVE-2026-68871?

CVE-2026-68871 is a medium-severity missing authorization vulnerability in Apache Airflow Yandex provider, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Yandex Lockbox secrets backend in Apache Airflow's Yandex provider resolved a team-scoped Connection or Variable id through the team-agnostic lookup when the team-scoped lookup missed. In a deployment running multi-team mode with this backend, a caller in one team could resolve a secret belonging to another team by supplying an id that spells out that team's namespace, obtaining its credentials in full. No unusual configuration is required beyond enabling multi-team mode and using this backend. Users are advised to upgrade to apache-airflow-providers-yandex 4.5.1 or later, which refuses the team-agnostic fall-through for an id that could name a team namespace.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-68871?

3 open source packages ship an affected version, including apache-airflow-providers-yandex. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-yandex` | PyPI | All versions | 4.5.1 |
| `apache-airflow-providers-yandex` | PyPI | All versions | 4.5.1 |
| `apache-airflow-providers-yandex` | PyPI | All versions | 4.5.1 |

Products: Apache Apache-Airflow-Providers-Apache-Yandex.

## How do I fix CVE-2026-68871?

Upgrade apache-airflow-providers-yandex to 4.5.1 or later.

## Is CVE-2026-68871 being exploited?

There is no known exploitation of CVE-2026-68871 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68871 and fix it if it is affected.

What it is: CVE-2026-68871 is a medium-severity missing authorization vulnerability in Apache Airflow Yandex provider, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-68871 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-yandex (PyPI): affected all versions; fixed in 4.5.1
- apache-airflow-providers-yandex (PyPI): affected all versions; fixed in 4.5.1
- apache-airflow-providers-yandex (PyPI): affected all versions; fixed in 4.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68871/ (Markdown: https://insights.sbomify.com/CVE-2026-68871/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68871
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68871
- OSV: https://osv.dev/vulnerability/CVE-2026-68871

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68871/
Summaries are generated and may contain mistakes; the official description above is the record.
