# CVE-2026-68901: Null dereference in wekan

> An attacker can cause a remote denial of service in Wekan by sending requests with invalid authentication tokens to board export endpoints, crashing the server process.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-3gcg-g6rf-w2rx

## What is CVE-2026-68901?

CVE-2026-68901 is a medium-severity vulnerability in wekan, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Wekan is open source kanban built with Meteor. Prior to 10.38, the /api/boards/:boardId/export, /api/boards/:boardId/attachments/:attachmentId/export, /api/boards/:boardId/export/csv, and /api/boards/:boardId/exportExcel handlers in models/export.js and models/exportExcel.js looked up a user from the attacker-controlled authToken query parameter and immediately called user._id.toString() without checking whether ReactiveCache.getUser() returned undefined. A request for a private board with an unknown token therefore threw a TypeError from an asynchronous route, producing an unhandled rejection that could terminate the Wekan process and deny service to all users. Version 10.38 adds a 401 guard after every export token lookup and wraps export handlers with safeRoute() so unexpected exceptions become controlled responses. This issue is fixed in version 10.38.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2026-68901?


## How do I fix CVE-2026-68901?

No fix has been published for CVE-2026-68901 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-68901 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68901 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68901 and fix it if it is affected.

What it is: CVE-2026-68901 is a medium-severity vulnerability in wekan, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68901 exists.

Affected product: wekan. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68901/ (Markdown: https://insights.sbomify.com/CVE-2026-68901/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68901
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68901
- OSV: https://osv.dev/vulnerability/CVE-2026-68901

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68901/
Summaries are generated and may contain mistakes; the official description above is the record.
