CVE-2026-68904 node-opcua: TCP Socket Leak (FIN-WAIT-2) via keepalive reconnection cycle - Resource Exhaustion

High 7.0 Published Updated

Attackers can cause resource exhaustion and process termination in node-opcua clients by triggering repeated reconnection cycles due to clock skew handling.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-68904?

CVE-2026-68904 is a high-severity denial of service vulnerability in node-opcua, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

node-opcua is an OPC UA implementation for TypeScript and Node.js. From 2.0.0 until 2.170.0, node-opcua clients using the default keepSessionAlive setting can enter a repeated reconnection cycle when an OPC UA server's clock skew causes BadInvalidTimestamp responses. ClientSessionKeepAliveManager._ping_server treated the server-originated ServiceFault as a network outage and forced a transport reconnect, while ClientTCP_transport._on_ACK_response used socket.end() after failed HEL/ACK negotiation and could leave the connection in FIN-WAIT-2 when the peer did not close. Repetition at the keepAliveInterval accumulates file descriptors and memory until the client process or container can be terminated by resource exhaustion. This issue is fixed in version 2.170.0.

Weakness: CWE-400

Which versions are affected by CVE-2026-68904?

6 open source packages ship an affected version, including node-opcua, node-opcua-client and node-opcua-transport.

PackageAffectedFixed in
node-opcua npmFrom 2.0.02.170.0
node-opcua npmFrom 2.0.02.170.0
node-opcua-client npmFrom 2.0.02.170.0
node-opcua-client npmFrom 2.0.02.170.0
node-opcua-transport npmFrom 2.0.02.170.0
node-opcua-transport npmFrom 2.0.02.170.0

How do I fix CVE-2026-68904?

Upgrade node-opcua to 2.170.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-68904 being exploited?

There is no known exploitation of CVE-2026-68904 in the wild and no public exploit code.

Sources

Also known as GHSA-r2pf-9cw4-5j65.

Is CVE-2026-68904 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free