# CVE-2026-68904: node-opcua: TCP Socket Leak (FIN-WAIT-2) via keepalive reconnection cycle - Resource Exhaustion

> Attackers can cause resource exhaustion and process termination in node-opcua clients by triggering repeated reconnection cycles due to clock skew handling.

- **Severity:** High 7.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-r2pf-9cw4-5j65

## What is CVE-2026-68904?

CVE-2026-68904 is a high-severity denial of service vulnerability in node-opcua, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

node-opcua is an OPC UA implementation for TypeScript and Node.js. From 2.0.0 until 2.170.0, node-opcua clients using the default keepSessionAlive setting can enter a repeated reconnection cycle when an OPC UA server's clock skew causes BadInvalidTimestamp responses. ClientSessionKeepAliveManager._ping_server treated the server-originated ServiceFault as a network outage and forced a transport reconnect, while ClientTCP_transport._on_ACK_response used socket.end() after failed HEL/ACK negotiation and could leave the connection in FIN-WAIT-2 when the peer did not close. Repetition at the keepAliveInterval accumulates file descriptors and memory until the client process or container can be terminated by resource exhaustion. This issue is fixed in version 2.170.0.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-68904?

6 open source packages ship an affected version, including node-opcua, node-opcua-client and node-opcua-transport.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node-opcua` | npm | From 2.0.0 | 2.170.0 |
| `node-opcua` | npm | From 2.0.0 | 2.170.0 |
| `node-opcua-client` | npm | From 2.0.0 | 2.170.0 |
| `node-opcua-client` | npm | From 2.0.0 | 2.170.0 |
| `node-opcua-transport` | npm | From 2.0.0 | 2.170.0 |
| `node-opcua-transport` | npm | From 2.0.0 | 2.170.0 |

## How do I fix CVE-2026-68904?

Upgrade node-opcua to 2.170.0 or later.

## Is CVE-2026-68904 being exploited?

There is no known exploitation of CVE-2026-68904 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68904 and fix it if it is affected.

What it is: CVE-2026-68904 is a high-severity denial of service vulnerability in node-opcua, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-68904 in the wild and no public exploit code.

Affected packages and fixed versions:
- node-opcua (npm): affected from 2.0.0; fixed in 2.170.0
- node-opcua (npm): affected from 2.0.0; fixed in 2.170.0
- node-opcua-client (npm): affected from 2.0.0; fixed in 2.170.0
- node-opcua-client (npm): affected from 2.0.0; fixed in 2.170.0
- node-opcua-transport (npm): affected from 2.0.0; fixed in 2.170.0
- node-opcua-transport (npm): affected from 2.0.0; fixed in 2.170.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68904/ (Markdown: https://insights.sbomify.com/CVE-2026-68904/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68904
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68904
- OSV: https://osv.dev/vulnerability/CVE-2026-68904

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68904/
Summaries are generated and may contain mistakes; the official description above is the record.
