# CVE-2026-68906: libIEC61850: Infinite loop and out-of-bounds read in ACSE parseUserInformation when parsing a malformed AARE PDU

> An unauthenticated remote attacker can cause a denial of service via infinite loop or crash by sending a malformed AARE PDU to libIEC61850.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Oct 2026
- **Updated:** 19 Oct 2026
- **Also known as:** GHSA-f7xm-q62q-22cx

## What is CVE-2026-68906?

CVE-2026-68906 is a high-severity denial of service vulnerability in mz-automation libiec61850, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libIEC61850 is an open-source implementation of IEC 61850 client and server protocols including MMS, GOOSE, Sampled Values, and R-Session. Prior to 1.6.2, parseUserInformation in src/mms/iso_acse/acse.c checks len for zero before validating the negative bufPos returned by BerDecoder_decodeLength for a truncated long-form length. The continue path therefore swallows the error, reads buffer[-1], resets parsing to the beginning, and repeats the same malformed state. An unauthenticated remote peer can send a malformed AARE PDU during association to cause an infinite CPU loop under a normal allocator or a one-byte out-of-bounds read and process abort when the preceding byte is inaccessible. This issue is fixed in version 1.6.2.

Weakness: CWE-835 (Loop with Unreachable Exit Condition), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-68906?


## How do I fix CVE-2026-68906?

No fix has been published for CVE-2026-68906 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-68906 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68906 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68906 and fix it if it is affected.

What it is: CVE-2026-68906 is a high-severity denial of service vulnerability in mz-automation libiec61850, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68906 exists.

Affected product: mz-automation libiec61850. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68906/ (Markdown: https://insights.sbomify.com/CVE-2026-68906/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68906
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68906
- OSV: https://osv.dev/vulnerability/CVE-2026-68906

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68906/
Summaries are generated and may contain mistakes; the official description above is the record.
