# CVE-2026-68907: Memory corruption in libiec61850

> Remote attackers can crash IEC 61850 servers via malformed requests due to a stack buffer over-read in libIEC61850 when dynamic datasets are enabled.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Oct 2026
- **Updated:** 16 Oct 2026

## What is CVE-2026-68907?

CVE-2026-68907 is a high-severity memory corruption vulnerability in mz-automation libiec61850, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libIEC61850 is an open-source implementation of IEC 61850 client and server protocols including MMS, GOOSE, Sampled Values, and R-Session. Prior to 1.6.2, checkDataSetAccess reverses the source and destination arguments to StringUtils_copyStringToBuffer while constructing an MMS_ASSOCIATION_SPECIFIC dataset reference. The helper treats uninitialized dataSetRef[130] storage as a source string, causing strlen to read beyond the stack buffer, and then copies those bytes into the caller-owned listName buffer. A remote defineNamedVariableList request can crash servers that have dynamic dataset service enabled and a dataset access handler installed; the advisory also observes caller stack corruption but establishes denial of service as the primary impact. This issue is fixed in version 1.6.2.

Weakness: CWE-628 (Function Call with Incorrectly Specified Arguments), CWE-457 (Use of Uninitialized Variable), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-68907?


## How do I fix CVE-2026-68907?

No fix has been published for CVE-2026-68907 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-68907 being exploited?

There is no known exploitation of CVE-2026-68907 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68907 and fix it if it is affected.

What it is: CVE-2026-68907 is a high-severity memory corruption vulnerability in mz-automation libiec61850, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-68907 in the wild and no public exploit code.

Affected product: mz-automation libiec61850. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68907/ (Markdown: https://insights.sbomify.com/CVE-2026-68907/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68907
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68907
- OSV: https://osv.dev/vulnerability/CVE-2026-68907

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68907/
Summaries are generated and may contain mistakes; the official description above is the record.
