# CVE-2026-68908: libIEC61850: Oversized RptID can trigger invalid free of a stack-backed visible string in the report send path

> A remote attacker can crash the IEC 61850 server by sending an oversized report ID, causing an invalid free of a stack buffer.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Oct 2026
- **Updated:** 16 Oct 2026

## What is CVE-2026-68908?

CVE-2026-68908 is a medium-severity memory corruption vulnerability in mz-automation libiec61850, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libIEC61850 is an open-source implementation of IEC 61850 client and server protocols including MMS, GOOSE, Sampled Values, and R-Session. Prior to 1.6.2, Reporting_RCBWriteAccessHandler accepts an RptID longer than 129 bytes in the report-control-block write path. When GI later causes sendNextReportEntrySegment to serialize the report, the function wraps rptIdBuf[130] as a temporary MmsValue and passes it to MmsValue_setVisibleString. The setter's resize path frees the stack-backed buffer, allowing a remote client to trigger an invalid free and server crash by writing the oversized RptID and then generating a report. This issue is fixed in version 1.6.2.

Weakness: CWE-763 (Release of Invalid Pointer or Reference), CWE-664 (Improper Control of a Resource Through its Lifetime), CWE-590 (Free of Memory not on the Heap)

## Which versions are affected by CVE-2026-68908?


## How do I fix CVE-2026-68908?

No fix has been published for CVE-2026-68908 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-68908 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68908 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68908 and fix it if it is affected.

What it is: CVE-2026-68908 is a medium-severity memory corruption vulnerability in mz-automation libiec61850, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68908 exists.

Affected product: mz-automation libiec61850. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68908/ (Markdown: https://insights.sbomify.com/CVE-2026-68908/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68908
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68908
- OSV: https://osv.dev/vulnerability/CVE-2026-68908

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68908/
Summaries are generated and may contain mistakes; the official description above is the record.
