# CVE-2026-68927: MobSF: SSRF port restriction bypass in assetlinks_check

> An authenticated user can bypass port restrictions in MobSF to perform Server-Side Request Forgery against internal services via crafted APKs.

- **Severity:** Low 3.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-95px-34x5-p37h, PYSEC-2026-3690

## What is CVE-2026-68927?

CVE-2026-68927 is a low-severity server-side request forgery vulnerability in Mobile-Security-Framework-MobSF, published on 18 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

MobSF is a mobile application security testing tool used. Prior to 4.5.1, get_browsable_activities in mobsf/StaticAnalyzer/views/android/manifest_analysis.py validates only an Android manifest android:host value with valid_host before appending a separately supplied android:port to the URL fetched by _check_url, allowing an authenticated user to upload a crafted APK that makes requests to an attacker-selected nonstandard port at /.well-known/assetlinks.json. With an attacker-controlled hostname and DNS rebinding between validation and the requests.get connection, the request can reach an internal service, although redirects remain disabled and the path is fixed. This issue is fixed in version 4.5.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-68927?

3 open source packages ship an affected version, including mobsf.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mobsf` | PyPI | All versions | 4.5.1 |
| `mobsf` | PyPI | All versions | 4.5.1 |
| `mobsf` | PyPI | All versions | 4.5.1 |

## How do I fix CVE-2026-68927?

Upgrade mobsf to 4.5.1 or later.

## Is CVE-2026-68927 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68927 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68927 and fix it if it is affected.

What it is: CVE-2026-68927 is a low-severity server-side request forgery vulnerability in Mobile-Security-Framework-MobSF, published on 18 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68927 exists.

Affected packages and fixed versions:
- mobsf (PyPI): affected all versions; fixed in 4.5.1
- mobsf (PyPI): affected all versions; fixed in 4.5.1
- mobsf (PyPI): affected all versions; fixed in 4.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68927/ (Markdown: https://insights.sbomify.com/CVE-2026-68927/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68927
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68927
- OSV: https://osv.dev/vulnerability/CVE-2026-68927

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68927/
Summaries are generated and may contain mistakes; the official description above is the record.
