{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68939 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-68939 is a low-severity command injection vulnerability in pyenv, published on 18 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-68939 and fix it if it is affected.\n\nWhat it is: CVE-2026-68939 is a low-severity command injection vulnerability in pyenv, published on 18 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68939 exists.\n\nAffected product: pyenv. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-68939/ (Markdown: https://insights.sbomify.com/CVE-2026-68939/index.md)","id":"CVE-2026-68939","markdown":"https://insights.sbomify.com/CVE-2026-68939/index.md","name":"CVE-2026-68939","record":{"aliases":["DEBIAN-CVE-2026-68939","GHSA-g478-f579-9vp9","UBUNTU-CVE-2026-68939","openSUSE-SU-2026:11613-1","openSUSE-SU-2026:21664-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python version manager","requires_auth":"low_privilege","summary":"Attackers can exploit unquoted glob expansion in pyenv to silently substitute Python interpreters, potentially leading to code execution or security bypass.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"},{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-155","name":"Improper Neutralization of Wildcards or Matching Symbols"}],"description":"Pyenv provides simple Python version management. Prior to 2.8.0, is_version_safe() in libexec/pyenv-version-file-read accepts shell glob metacharacters in .python-version values, and unquoted PYENV_VERSION expansion in libexec/pyenv-version-name, libexec/pyenv-which, libexec/pyenv-prefix, libexec/pyenv-local, libexec/pyenv-global, libexec/pyenv-version, and libexec/pyenv-versions pathname-expands the value against the current directory, allowing a matching attacker-controlled file to silently select a different installed interpreter or version. This issue is fixed in version 2.8.0.","ecosystems":["openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Command injection in pyenv","id":"CVE-2026-68939","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Angular: Cache-Key Ambiguity in HttpTransferCache Leading to Cross-Request Response Reuse and State Poisoning","id":"CVE-2026-68945"},"packages":[{"ecosystem":"openSUSE:Leap 16.0","fixed":["2.4.14-bp160.2.1"],"introduced":["0"],"last_affected":[],"package":"pyenv","purl":"pkg:rpm/opensuse/pyenv\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:21664-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.8.4-1.1"],"introduced":["0"],"last_affected":[],"package":"pyenv","purl":"pkg:rpm/opensuse/pyenv\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11613-1"}],"prev":{"headline":"Russh: Channel-scoped server callbacks can be reached without an open channel","id":"CVE-2026-68930"},"products":["pyenv"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-18","vendors":["pyenv"]},"summary":"Attackers can exploit unquoted glob expansion in pyenv to silently substitute Python interpreters, potentially leading to code execution or security bypass.","url":"https://insights.sbomify.com/CVE-2026-68939/"}