# CVE-2026-68939: Command injection in pyenv

> Attackers can exploit unquoted glob expansion in pyenv to silently substitute Python interpreters, potentially leading to code execution or security bypass.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-68939, GHSA-g478-f579-9vp9, UBUNTU-CVE-2026-68939, openSUSE-SU-2026:11613-1, openSUSE-SU-2026:21664-1

## What is CVE-2026-68939?

CVE-2026-68939 is a low-severity command injection vulnerability in pyenv, published on 18 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Pyenv provides simple Python version management. Prior to 2.8.0, is_version_safe() in libexec/pyenv-version-file-read accepts shell glob metacharacters in .python-version values, and unquoted PYENV_VERSION expansion in libexec/pyenv-version-name, libexec/pyenv-which, libexec/pyenv-prefix, libexec/pyenv-local, libexec/pyenv-global, libexec/pyenv-version, and libexec/pyenv-versions pathname-expands the value against the current directory, allowing a matching attacker-controlled file to silently select a different installed interpreter or version. This issue is fixed in version 2.8.0.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command), CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-155 (Improper Neutralization of Wildcards or Matching Symbols)

## Which versions are affected by CVE-2026-68939?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyenv` | openSUSE:Leap 16.0 | All versions | 2.4.14-bp160.2.1 |
| `pyenv` | openSUSE:Tumbleweed | All versions | 2.8.4-1.1 |

## How do I fix CVE-2026-68939?

Upgrade to a fixed version.

## Is CVE-2026-68939 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68939 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68939 and fix it if it is affected.

What it is: CVE-2026-68939 is a low-severity command injection vulnerability in pyenv, published on 18 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-68939 exists.

Affected product: pyenv. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68939/ (Markdown: https://insights.sbomify.com/CVE-2026-68939/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68939
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68939
- OSV: https://osv.dev/vulnerability/CVE-2026-68939

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68939/
Summaries are generated and may contain mistakes; the official description above is the record.
