CVE-2026-68968 Apache Airflow: Authorization bypass in the Backfill API through conflicting interpretations of the backfill id

High 7.5 Published Updated

Authenticated users can bypass authorization checks to read, pause, or cancel backfills of other Dags due to inconsistent ID parsing logic.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-68968?

CVE-2026-68968 is a high-severity missing authorization vulnerability in Apache Airflow, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Apache Airflow's Backfill API authorized a request against a Dag id supplied by the caller whenever the `backfill_id` path segment failed to parse. The authorization dependency parsed it with `int()` while the route handler parsed it as pydantic's `NonNegativeInt`, which accepts values `int()` rejects (`1.0` coerces to `1`); FastAPI resolves dependencies before endpoint validation, so the two acted on different Dags. An authenticated user holding edit permission on any single Dag could therefore read, pause and cancel backfills belonging to any other Dag, including moving another Dag's queued runs to `failed`. No non-default configuration is required and backfill ids are sequential, so finding a target is trivial. Users are advised to upgrade to apache-airflow 3.3.1 or later, which parses the backfill id with the same type the routes declare.

Weakness: CWE-436

Which versions are affected by CVE-2026-68968?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIAll versions3.3.1
apache-airflow PyPIAll versions3.3.1
apache-airflow PyPIAll versions3.3.1
airflow BitnamiAll versions3.3.1

Products include Apache Airflow.

How do I fix CVE-2026-68968?

Upgrade apache-airflow to 3.3.1 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-68968 being exploited?

There is no known exploitation of CVE-2026-68968 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2026-68968, CLEANSTART-2026-OM50067, ECHO-15a1-9bf1-c341, GHSA-j4jc-cq9h-xrhr, MINI-67mw-5rpc-r3p2, MINI-6cwc-5h8g-5cjh and 1 more.

Is CVE-2026-68968 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free