# CVE-2026-68968: Apache Airflow: Authorization bypass in the Backfill API through conflicting interpretations of the backfill id

> Authenticated users can bypass authorization checks to read, pause, or cancel backfills of other Dags due to inconsistent ID parsing logic.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 16 Sep 2026
- **Also known as:** BIT-airflow-2026-68968, CLEANSTART-2026-OM50067, ECHO-15a1-9bf1-c341, GHSA-j4jc-cq9h-xrhr, MINI-67mw-5rpc-r3p2, MINI-6cwc-5h8g-5cjh, PYSEC-2026-3710

## What is CVE-2026-68968?

CVE-2026-68968 is a high-severity missing authorization vulnerability in Apache Airflow, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Airflow's Backfill API authorized a request against a Dag id supplied by the caller whenever the `backfill_id` path segment failed to parse. The authorization dependency parsed it with `int()` while the route handler parsed it as pydantic's `NonNegativeInt`, which accepts values `int()` rejects (`1.0` coerces to `1`); FastAPI resolves dependencies before endpoint validation, so the two acted on different Dags. An authenticated user holding edit permission on any single Dag could therefore read, pause and cancel backfills belonging to any other Dag, including moving another Dag's queued runs to `failed`. No non-default configuration is required and backfill ids are sequential, so finding a target is trivial. Users are advised to upgrade to apache-airflow 3.3.1 or later, which parses the backfill id with the same type the routes declare.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-68968?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 3.3.1 |
| `apache-airflow` | PyPI | All versions | 3.3.1 |
| `apache-airflow` | PyPI | All versions | 3.3.1 |
| `airflow` | Bitnami | All versions | 3.3.1 |

Products: Apache Airflow.

## How do I fix CVE-2026-68968?

Upgrade apache-airflow to 3.3.1 or later.

## Is CVE-2026-68968 being exploited?

There is no known exploitation of CVE-2026-68968 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68968 and fix it if it is affected.

What it is: CVE-2026-68968 is a high-severity missing authorization vulnerability in Apache Airflow, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-68968 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 3.3.1
- apache-airflow (PyPI): affected all versions; fixed in 3.3.1
- apache-airflow (PyPI): affected all versions; fixed in 3.3.1
- airflow (Bitnami): affected all versions; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68968/ (Markdown: https://insights.sbomify.com/CVE-2026-68968/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68968
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68968
- OSV: https://osv.dev/vulnerability/CVE-2026-68968

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68968/
Summaries are generated and may contain mistakes; the official description above is the record.
