# CVE-2026-68970: Apache Airflow: Values of a list-shaped Variable are not masked in task logs and the Rendered Templates UI

> Authenticated users can view unmasked secrets stored as list-shaped Variables in Apache Airflow task logs and rendered templates.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 16 Sep 2026
- **Also known as:** BIT-airflow-2026-68970, CLEANSTART-2026-GP65571, CLEANSTART-2026-UV14417, ECHO-66ca-b82c-a1c7, GHSA-f3c2-j7g8-vpp8, MINI-66mh-p266-qw55, MINI-w69v-hjpp-9x8f, PYSEC-2026-3712

## What is CVE-2026-68970?

CVE-2026-68970 is a medium-severity vulnerability in Apache Airflow, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow's Task SDK did not mask the contents of a Variable whose JSON value is a list, so secrets stored in that shape appeared in cleartext in task logs and in the Rendered Templates UI. Masking was applied only when the deserialized value was a string or a dict; a list at the top level matched neither and was returned unmasked. Any authenticated user able to read the logs or rendered templates of a task that references such a Variable could recover the values, with no special configuration required. This is the list-shaped counterpart of CVE-2026-59244, whose fix covered the dict case only, so deployments that upgraded in response to that advisory remain affected and must upgrade again. Users are advised to upgrade to apache-airflow 3.3.1 or later.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2026-68970?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 3.3.1 |
| `apache-airflow` | PyPI | All versions | 3.3.1 |
| `apache-airflow` | PyPI | All versions | 3.3.1 |
| `airflow` | Bitnami | All versions | 3.3.1 |

Products: Apache Airflow.

## How do I fix CVE-2026-68970?

Upgrade apache-airflow to 3.3.1 or later.

## Is CVE-2026-68970 being exploited?

There is no known exploitation of CVE-2026-68970 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68970 and fix it if it is affected.

What it is: CVE-2026-68970 is a medium-severity vulnerability in Apache Airflow, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-68970 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 3.3.1
- apache-airflow (PyPI): affected all versions; fixed in 3.3.1
- apache-airflow (PyPI): affected all versions; fixed in 3.3.1
- airflow (Bitnami): affected all versions; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68970/ (Markdown: https://insights.sbomify.com/CVE-2026-68970/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68970
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68970
- OSV: https://osv.dev/vulnerability/CVE-2026-68970

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68970/
Summaries are generated and may contain mistakes; the official description above is the record.
