# CVE-2026-68971: Apache Airflow: Cross-team authorization bypass in the asset materialization and dag-run result endpoints

> Authenticated users in multi-team deployments can bypass team restrictions to trigger other teams' DAGs and read their XCom values.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 16 Sep 2026
- **Also known as:** BIT-airflow-2026-68971, CLEANSTART-2026-UI77772, ECHO-2ade-2881-4886, GHSA-5247-m8w9-2v4m, MINI-cf5j-pjr6-gxw4, MINI-q57r-8qwf-8c4f, PYSEC-2026-3994

## What is CVE-2026-68971?

CVE-2026-68971 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow's asset materialization endpoint (`POST /api/v2/assets/{asset_id}/materialize`) and the XCom result check on `wait_dag_run_until_finished` authorized the target Dag without its team, unlike every other authorization site. A team-aware auth manager distinguishes a team-scoped Dag from a global one by that field -- the Keycloak auth manager, for example, checks the `DAG` resource instead of `DAG:<team>` -- so the team-scoped permission that should gate the request was never consulted. In a deployment running multi-team mode with a team-aware auth manager, an authenticated user in one team could trigger Dag runs belonging to another team, supplying their own `dag_run_id` and `conf`, and could read another team's XCom values. Deployments using the FAB auth manager are unaffected, as it has no multi-team support. Users are advised to upgrade to apache-airflow 3.3.1 or later, which resolves the Dag's team at both sites.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-68971?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 3.3.1 |
| `apache-airflow` | PyPI | All versions | 3.3.1 |
| `apache-airflow` | PyPI | All versions | 3.3.1 |
| `airflow` | Bitnami | All versions | 3.3.1 |

Products: Apache Airflow.

## How do I fix CVE-2026-68971?

Upgrade apache-airflow to 3.3.1 or later.

## Is CVE-2026-68971 being exploited?

There is no known exploitation of CVE-2026-68971 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68971 and fix it if it is affected.

What it is: CVE-2026-68971 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-68971 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 3.3.1
- apache-airflow (PyPI): affected all versions; fixed in 3.3.1
- apache-airflow (PyPI): affected all versions; fixed in 3.3.1
- airflow (Bitnami): affected all versions; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68971/ (Markdown: https://insights.sbomify.com/CVE-2026-68971/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68971
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68971
- OSV: https://osv.dev/vulnerability/CVE-2026-68971

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68971/
Summaries are generated and may contain mistakes; the official description above is the record.
