# CVE-2026-68979: Apache NiFi: Missing Authorization for Components Referenced by Parameter Context Updates

> Authenticated users can bypass component authorization to modify parameters, potentially leading to code execution in deployments using component-level policies.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:H/VA:L/SC:L/SI:L/SA:L/S:N/AU:Y/R:U/V:C/RE:L/U:Clear`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** BIT-nifi-2026-68979, GHSA-p3jm-q7cw-g645, MINI-6gjg-f26q-qjmq

## What is CVE-2026-68979?

CVE-2026-68979 is a medium-severity missing authorization vulnerability in Apache Nifi, published on 3 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Apache NiFI 1.10.0 through 2.10.0 provide a Parameter Context update REST API method that does not enforce authorization checking on components referencing Parameter values. Updating a Parameter Context can change parameter values that affect referencing components, but framework authorization was limited to read and write privileges on the Parameter Context itself. As a result of the missing authorization, an authenticated user authorized to modify a Parameter Context, but not authorized on referencing components, could alter Parameter values affecting those components. In deployments where a Parameter value contains executable scripting content, updating a Parameter can result in code execution during automatic component validation, without starting the referencing component. The impact was limited to stopped components by existing verification checks, and the issue applies only to deployments that use component-level authorization policies. Upgrading to Apache NiFi 2.11.0 is the recommended mitigation, which aligns the Parameter Context update method authorization with other methods, adding authorization checking on affected components.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-68979?

1 open source package ship an affected version, including nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nifi` | Bitnami | From 1.10.0 | 2.11.0 |

Products: Apache Nifi.

## How do I fix CVE-2026-68979?

Upgrade nifi to 2.11.0 or later.

## Is CVE-2026-68979 being exploited?

There is no known exploitation of CVE-2026-68979 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68979 and fix it if it is affected.

What it is: CVE-2026-68979 is a medium-severity missing authorization vulnerability in Apache Nifi, published on 3 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-68979 in the wild and no public exploit code.

Affected packages and fixed versions:
- nifi (Bitnami): affected from 1.10.0; fixed in 2.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68979/ (Markdown: https://insights.sbomify.com/CVE-2026-68979/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68979
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68979
- OSV: https://osv.dev/vulnerability/CVE-2026-68979

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68979/
Summaries are generated and may contain mistakes; the official description above is the record.
