# CVE-2026-68980: Apache NiFi: Authorization Bypass for Parameter Context Asset Deletion

> Attackers can delete Parameter Context assets without proper ownership verification if granular authorization is configured, requiring an upgrade to fix.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/S:N/AU:Y/R:U/V:C/RE:L/U:Clear`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Aug 2026
- **Updated:** 4 Aug 2026
- **Also known as:** BIT-nifi-2026-68980, GHSA-xq5v-6pm7-4qw9, MINI-xcx7-w9h9-wg2h

## What is CVE-2026-68980?

CVE-2026-68980 is a low-severity missing authorization vulnerability in Apache Nifi, published on 3 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache NiFi 2.0.0 through 2.10.0 support creating, reading, and deleting Assets associated with Parameter Contexts through the REST API. The framework authorizes asset deletion against the owning Parameter Context using the supplied Parameter Context Identifier and Asset Identifier. The framework performed authorized based on the supplied Parameter Context Identifier without verifying the requested Identifier against the stored Identifier. Apache NiFi installations that do not implement different levels of authorization across Parameter Contexts are not subject to this vulnerability, because the framework enforces write permissions as the security boundary. Upgrading to Apache NiFi 2.11.0 is the recommended mitigation, which verifies Parameter Context ownership of the requested Asset before deletion using the same strategy applied to Asset read operations.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-68980?

1 open source package ship an affected version, including nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nifi` | Bitnami | From 2.0.0 | 2.11.0 |

Products: Apache Nifi.

## How do I fix CVE-2026-68980?

Upgrade nifi to 2.11.0 or later.

## Is CVE-2026-68980 being exploited?

There is no known exploitation of CVE-2026-68980 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68980 and fix it if it is affected.

What it is: CVE-2026-68980 is a low-severity missing authorization vulnerability in Apache Nifi, published on 3 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-68980 in the wild and no public exploit code.

Affected packages and fixed versions:
- nifi (Bitnami): affected from 2.0.0; fixed in 2.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68980/ (Markdown: https://insights.sbomify.com/CVE-2026-68980/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68980
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68980
- OSV: https://osv.dev/vulnerability/CVE-2026-68980

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68980/
Summaries are generated and may contain mistakes; the official description above is the record.
