{"answers":{"affected":"1 open source package ship an affected version, including nifi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-68981 in the wild and no public exploit code.","fix":"Upgrade nifi to 2.11.0 or later.","what":"CVE-2026-68981 is a high-severity denial of service vulnerability in Apache Nifi, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-68981 and fix it if it is affected.\n\nWhat it is: CVE-2026-68981 is a high-severity denial of service vulnerability in Apache Nifi, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-68981 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nifi (Bitnami): affected from 1.5.0; fixed in 2.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-68981/ (Markdown: https://insights.sbomify.com/CVE-2026-68981/index.md)","id":"CVE-2026-68981","markdown":"https://insights.sbomify.com/CVE-2026-68981/index.md","name":"CVE-2026-68981","record":{"aliases":["BIT-nifi-2026-68981","GHSA-w96g-mj2p-wqjv","MINI-8p3q-3p5f-vx3q"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache NiFi","requires_auth":"none","summary":"Attackers can cause excessive memory consumption and denial of service in Apache NiFi by sending crafted gzip-encoded HTTP requests to the REST API.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"nifi","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N/S:P/AU:Y/R:U/V:C/RE:M/U:Amber","version":"4.0"},"cwes":[{"id":"CWE-409","name":"Improper Handling of Highly Compressed Data (Data Amplification)"}],"description":"Apache NiFi 1.5.0 through 2.10.0 support gzip-encoded HTTP requests for the application REST API using a Jersey encoding filter. The framework enforced a configurable maximum request size on the compressed payload rather than the decompressed output, allowing a malicious client to send crafted requests that could consume excessive amounts of memory. Upgrading to Apache NiFi 2.11.0 is the recommended mitigation, which relocates response compression to Jetty Server and disables decompression of gzip-encoded HTTP requests.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests","id":"CVE-2026-68981","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:nifi","products":["apache:nifi"],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Stored Cross-Site Scripting via Vue Template Injection in FlowIntel","id":"CVE-2026-69075"},"packages":[{"ecosystem":"Bitnami","fixed":["2.11.0"],"introduced":["1.5.0"],"last_affected":[],"package":"nifi","purl":"pkg:bitnami/nifi","source":"BIT-nifi-2026-68981"}],"prev":{"headline":"Apache NiFi: Authorization Bypass for Parameter Context Asset Deletion","id":"CVE-2026-68980"},"products":["Apache NiFi"],"published":"2026-08-03","related":[{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache NiFi","id":"CVE-2018-1309","kev_date_added":null,"published":"2018-05-23"},{"cvss_score":9.8,"headline":"Apache NiFi XSS issue in context path handling","id":"CVE-2017-15697","kev_date_added":null,"published":"2018-01-23"},{"cvss_score":9.8,"headline":"Injection in Apache NiFi","id":"CVE-2017-5636","kev_date_added":null,"published":"2017-10-19"},{"cvss_score":8.8,"headline":"Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources","id":"CVE-2023-36542","kev_date_added":null,"published":"2023-07-29"},{"cvss_score":8.8,"headline":"Apache NiFi: Potential Code Injection with Database Services using H2","id":"CVE-2023-34468","kev_date_added":null,"published":"2023-06-12"},{"cvss_score":8.8,"headline":"Improper Neutralization of Command Elements in Shell User Group Provider","id":"CVE-2022-33140","kev_date_added":null,"published":"2022-06-15"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-04","vendors":["Apache Software Foundation"]},"summary":"Attackers can cause excessive memory consumption and denial of service in Apache NiFi by sending crafted gzip-encoded HTTP requests to the REST API.","url":"https://insights.sbomify.com/CVE-2026-68981/"}