# CVE-2026-68981: Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests

> Attackers can cause excessive memory consumption and denial of service in Apache NiFi by sending crafted gzip-encoded HTTP requests to the REST API.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N/S:P/AU:Y/R:U/V:C/RE:M/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Aug 2026
- **Updated:** 4 Aug 2026
- **Also known as:** BIT-nifi-2026-68981, GHSA-w96g-mj2p-wqjv, MINI-8p3q-3p5f-vx3q

## What is CVE-2026-68981?

CVE-2026-68981 is a high-severity denial of service vulnerability in Apache Nifi, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache NiFi 1.5.0 through 2.10.0 support gzip-encoded HTTP requests for the application REST API using a Jersey encoding filter. The framework enforced a configurable maximum request size on the compressed payload rather than the decompressed output, allowing a malicious client to send crafted requests that could consume excessive amounts of memory. Upgrading to Apache NiFi 2.11.0 is the recommended mitigation, which relocates response compression to Jetty Server and disables decompression of gzip-encoded HTTP requests.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-68981?

1 open source package ship an affected version, including nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nifi` | Bitnami | From 1.5.0 | 2.11.0 |

Products: Apache Nifi.

## How do I fix CVE-2026-68981?

Upgrade nifi to 2.11.0 or later.

## Is CVE-2026-68981 being exploited?

There is no known exploitation of CVE-2026-68981 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)
- [CVE-2023-34468](https://insights.sbomify.com/CVE-2023-34468/): Apache NiFi: Potential Code Injection with Database Services using H2 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68981 and fix it if it is affected.

What it is: CVE-2026-68981 is a high-severity denial of service vulnerability in Apache Nifi, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-68981 in the wild and no public exploit code.

Affected packages and fixed versions:
- nifi (Bitnami): affected from 1.5.0; fixed in 2.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68981/ (Markdown: https://insights.sbomify.com/CVE-2026-68981/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68981
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68981
- OSV: https://osv.dev/vulnerability/CVE-2026-68981

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68981/
Summaries are generated and may contain mistakes; the official description above is the record.
