CVE-2026-69077 Apache Kylin: JobController allows unauthorized cross-project manipulation

High 7.5 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2026-69077?

CVE-2026-69077 is a high-severity vulnerability in Apache Kylin, published on 16 Oct 2026.

Official description

Exposure of unauthorized cross-project job manipulation vulnerability in Apache Kylin. Impact most to the kylin services that are directly exposed to public network, which is not common. In-house kylin deployments are mostly not impacted.

This issue affects Apache Kylin: from 4 through 5.0.4.

Users are recommended to upgrade to version 5.0.5, which fixes the issue.

Weakness: CWE-200

Which versions are affected by CVE-2026-69077?

How do I fix CVE-2026-69077?

No fix has been published for CVE-2026-69077 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-69077 being exploited?

There is no known exploitation of CVE-2026-69077 in the wild and no public exploit code.

Sources

Also known as GHSA-5wf3-g47p-2g8r.

Is CVE-2026-69077 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free