CVE-2026-69080 Apache Kylin: Broken Access Control in QuerySQLBlacklistController

High 7.5 Published Updated

An unauthorized actor can access the SQL Black List in Apache Kylin, potentially revealing sensitive configuration data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-69080?

CVE-2026-69080 is a high-severity vulnerability in Apache Kylin, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Exposure of SQL Black List to an Unauthorized Actor vulnerability in Apache Kylin.

This issue affects Apache Kylin: from 4 through 5.0.4.

Users are recommended to upgrade to version 5.0.5, which fixes the issue.

Weakness: CWE-200

Which versions are affected by CVE-2026-69080?

How do I fix CVE-2026-69080?

No fix has been published for CVE-2026-69080 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-69080 being exploited?

There is no known exploitation of CVE-2026-69080 in the wild and no public exploit code.

Sources

Also known as GHSA-2q75-3h97-94cq.

Is CVE-2026-69080 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free