# CVE-2026-69080: Apache Kylin: Broken Access Control in QuerySQLBlacklistController

> An unauthorized actor can access the SQL Black List in Apache Kylin, potentially revealing sensitive configuration data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-2q75-3h97-94cq

## What is CVE-2026-69080?

CVE-2026-69080 is a high-severity vulnerability in Apache Kylin, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Exposure of SQL Black List to an Unauthorized Actor vulnerability in Apache Kylin.

This issue affects Apache Kylin: from 4 through 5.0.4.

Users are recommended to upgrade to version 5.0.5, which fixes the issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-69080?


## How do I fix CVE-2026-69080?

No fix has been published for CVE-2026-69080 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-69080 being exploited?

There is no known exploitation of CVE-2026-69080 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69080 and fix it if it is affected.

What it is: CVE-2026-69080 is a high-severity vulnerability in Apache Kylin, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-69080 in the wild and no public exploit code.

Affected product: Apache Kylin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69080/ (Markdown: https://insights.sbomify.com/CVE-2026-69080/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69080
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69080
- OSV: https://osv.dev/vulnerability/CVE-2026-69080

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69080/
Summaries are generated and may contain mistakes; the official description above is the record.
