CVE-2026-69088 Grav CMS 2.0.7 through 2.0.10 Arbitrary Method Invocation via Blueprint
Attackers with page-editing rights can invoke arbitrary static PHP methods to read files or create directories via unsafe blueprint directives.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-69088?
CVE-2026-69088 is a high-severity code injection vulnerability in getgrav grav, published on 3 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Grav CMS versions 2.0.7 through 2.0.10 fail to validate fully-qualified static method calls (Class::method) in blueprint dynamic-field directives because Blueprint::isSafeDynamicCall() only applies its dangerous-callable denylist to strings that do not contain '::'. An account with only page-editing rights (admin.pages, not super-admin or admin.pages_twig) can plant a directive in a page's form-field frontmatter that invokes an arbitrary public static PHP method with attacker-controlled arguments. Using built-in gadget methods this allows reading of any server-readable file (disclosed to anonymous visitors of the crafted page) and arbitrary creation/copying of files and directories under the web-server account. Fixed in 2.0.11.
Weakness: CWE-94
Which versions are affected by CVE-2026-69088?
2 open source packages ship an affected version, including getgrav/grav.
| Package | Affected | Fixed in |
|---|---|---|
getgrav/grav Packagist | From 2.0.7 | 2.0.11 |
getgrav/grav Packagist | From 2.0.7 | 2.0.11 |
How do I fix CVE-2026-69088?
Upgrade getgrav/grav to 2.0.11 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-69088 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69088 exists.
Sources
Also known as GHSA-7pgq-cr25-xvc8.