{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69088 exists.","fix":"Upgrade getgrav/grav to 2.0.11 or later.","what":"CVE-2026-69088 is a high-severity code injection vulnerability in getgrav grav, published on 3 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-69088 and fix it if it is affected.\n\nWhat it is: CVE-2026-69088 is a high-severity code injection vulnerability in getgrav grav, published on 3 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69088 exists.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected from 2.0.7; fixed in 2.0.11\n- getgrav/grav (Packagist): affected from 2.0.7; fixed in 2.0.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-69088/ (Markdown: https://insights.sbomify.com/CVE-2026-69088/index.md)","id":"CVE-2026-69088","markdown":"https://insights.sbomify.com/CVE-2026-69088/index.md","name":"CVE-2026-69088","record":{"aliases":["GHSA-7pgq-cr25-xvc8"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav CMS","requires_auth":"low_privilege","summary":"Attackers with page-editing rights can invoke arbitrary static PHP methods to read files or create directories via unsafe blueprint directives.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Grav CMS versions 2.0.7 through 2.0.10 fail to validate fully-qualified static method calls (Class::method) in blueprint dynamic-field directives because Blueprint::isSafeDynamicCall() only applies its dangerous-callable denylist to strings that do not contain '::'. An account with only page-editing rights (admin.pages, not super-admin or admin.pages_twig) can plant a directive in a page's form-field frontmatter that invokes an arbitrary public static PHP method with attacker-controlled arguments. Using built-in gadget methods this allows reading of any server-readable file (disclosed to anonymous visitors of the crafted page) and arbitrary creation/copying of files and directories under the web-server account. Fixed in 2.0.11.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Grav CMS 2.0.7 through 2.0.10 Arbitrary Method Invocation via Blueprint","id":"CVE-2026-69088","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Grav CMS before 2.0.11 Path Traversal via watermark","id":"CVE-2026-69089"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.11"],"introduced":["2.0.7"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-7pgq-cr25-xvc8"},{"ecosystem":"Packagist","fixed":["2.0.11"],"introduced":["2.0.7"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-7pgq-cr25-xvc8"}],"prev":{"headline":"Grav Form Plugin before 9.1.13 Open Redirect via form.value() Twig","id":"CVE-2026-69087"},"products":["grav"],"published":"2026-08-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["getgrav"]},"summary":"Attackers with page-editing rights can invoke arbitrary static PHP methods to read files or create directories via unsafe blueprint directives.","url":"https://insights.sbomify.com/CVE-2026-69088/"}