# CVE-2026-69088: Grav CMS 2.0.7 through 2.0.10 Arbitrary Method Invocation via Blueprint

> Attackers with page-editing rights can invoke arbitrary static PHP methods to read files or create directories via unsafe blueprint directives.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-7pgq-cr25-xvc8

## What is CVE-2026-69088?

CVE-2026-69088 is a high-severity code injection vulnerability in getgrav grav, published on 3 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grav CMS versions 2.0.7 through 2.0.10 fail to validate fully-qualified static method calls (Class::method) in blueprint dynamic-field directives because Blueprint::isSafeDynamicCall() only applies its dangerous-callable denylist to strings that do not contain '::'. An account with only page-editing rights (admin.pages, not super-admin or admin.pages_twig) can plant a directive in a page's form-field frontmatter that invokes an arbitrary public static PHP method with attacker-controlled arguments. Using built-in gadget methods this allows reading of any server-readable file (disclosed to anonymous visitors of the crafted page) and arbitrary creation/copying of files and directories under the web-server account. Fixed in 2.0.11.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-69088?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | From 2.0.7 | 2.0.11 |
| `getgrav/grav` | Packagist | From 2.0.7 | 2.0.11 |

## How do I fix CVE-2026-69088?

Upgrade getgrav/grav to 2.0.11 or later.

## Is CVE-2026-69088 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69088 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69088 and fix it if it is affected.

What it is: CVE-2026-69088 is a high-severity code injection vulnerability in getgrav grav, published on 3 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69088 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected from 2.0.7; fixed in 2.0.11
- getgrav/grav (Packagist): affected from 2.0.7; fixed in 2.0.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69088/ (Markdown: https://insights.sbomify.com/CVE-2026-69088/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69088
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69088
- OSV: https://osv.dev/vulnerability/CVE-2026-69088

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69088/
Summaries are generated and may contain mistakes; the official description above is the record.
