# CVE-2026-69089: Grav CMS before 2.0.11 Path Traversal via watermark

> An attacker can exploit a path traversal flaw in Grav CMS to read arbitrary files outside the media sandbox and serve them publicly.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-w3f4-8pj2-599w

## What is CVE-2026-69089?

CVE-2026-69089 is a high-severity path traversal vulnerability in getgrav grav, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Grav CMS 2.0.10 contains a path traversal vulnerability in ImageMedium::watermark(), which passes its unsanitized $image argument to RocketTheme\Toolbox\ResourceLocator\UniformResourceLocator::findResource(). Because the file:// scheme branch only lexically collapses '..' segments without a realpath/containment check, an editor authoring Markdown image syntax with traversal sequences can cause arbitrary image files outside Grav's media sandbox to be composited into a carrier image, which is then cached and served from a public, unauthenticated URL — disclosing those files to anonymous visitors.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-69089?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | From 2.0.10 | 2.0.11 |
| `getgrav/grav` | Packagist | From 2.0.10 | 2.0.11 |

## How do I fix CVE-2026-69089?

Upgrade getgrav/grav to 2.0.11 or later.

## Is CVE-2026-69089 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69089 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69089 and fix it if it is affected.

What it is: CVE-2026-69089 is a high-severity path traversal vulnerability in getgrav grav, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69089 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected from 2.0.10; fixed in 2.0.11
- getgrav/grav (Packagist): affected from 2.0.10; fixed in 2.0.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69089/ (Markdown: https://insights.sbomify.com/CVE-2026-69089/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69089
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69089
- OSV: https://osv.dev/vulnerability/CVE-2026-69089

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69089/
Summaries are generated and may contain mistakes; the official description above is the record.
