# CVE-2026-69097: GitPython before 3.1.53 Config Injection via Submodule Names

> Attackers can achieve remote code execution by injecting malicious git config directives via submodule names in GitPython.

- **Severity:** High 7.3 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-69097, ECHO-6b19-bb0e-4e42, ECHO-6d73-52e6-3a0a, GHSA-3rp5-jjmw-4wv2, MINI-4fmj-jp92-65xp, MINI-4p3c-736m-4hgq, MINI-8cv6-88w6-3wqh, MINI-cxpf-2xr2-3h26, MINI-h64p-w94q-gvqv, MINI-qx4m-6rvw-cj2r, OESA-2026-3353, OESA-2026-3354, OESA-2026-3439, PYSEC-2026-3981, ROOT-APP-PYPI-GHSA-3rp5-jjmw-4wv2, UBUNTU-CVE-2026-69097

## What is CVE-2026-69097?

CVE-2026-69097 is a high-severity code injection vulnerability in gitpython-developers GitPython, published on 3 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

GitPython before 3.1.53 fails to properly escape section names in git config files, allowing attackers to inject arbitrary configuration directives through malicious submodule names. Attackers can inject core.sshCommand or other dangerous config keys into the victim's .git/config via create_submodule or clone_from operations, achieving remote code execution when git performs ssh operations.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-69097?

3 open source packages ship an affected version, including gitpython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | All versions | 3.1.53 |
| `gitpython` | PyPI | All versions | 3.1.53 |
| `gitpython` | PyPI | All versions | 3.1.53 |

Products: Gitpython Project Gitpython.

## How do I fix CVE-2026-69097?

Upgrade gitpython to 3.1.53 or later.

## Is CVE-2026-69097 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69097 exists.

## Other vulnerabilities in gitpython-developers GitPython

- [CVE-2023-40267](https://insights.sbomify.com/CVE-2023-40267/): GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments (critical 9.8)
- [CVE-2026-78676](https://insights.sbomify.com/CVE-2026-78676/): GitPython before 3.1.59 Remote Code Execution via Config Injection (critical 9.3)
- [CVE-2026-67324](https://insights.sbomify.com/CVE-2026-67324/): GitPython 3.1.50 Authentication Bypass via Joined Short Options (critical 9.3)
- [CVE-2026-42215](https://insights.sbomify.com/CVE-2026-42215/): GitPython: Command injection via Git options bypass (high 8.8)
- [CVE-2026-87817](https://insights.sbomify.com/CVE-2026-87817/): GitPython before 3.1.60 Remote Code Execution via Git Directory Impersonation (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-69097 and fix it if it is affected.

What it is: CVE-2026-69097 is a high-severity code injection vulnerability in gitpython-developers GitPython, published on 3 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-69097 exists.

Affected packages and fixed versions:
- gitpython (PyPI): affected all versions; fixed in 3.1.53
- gitpython (PyPI): affected all versions; fixed in 3.1.53
- gitpython (PyPI): affected all versions; fixed in 3.1.53

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-69097/ (Markdown: https://insights.sbomify.com/CVE-2026-69097/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-69097
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-69097
- OSV: https://osv.dev/vulnerability/CVE-2026-69097

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-69097/
Summaries are generated and may contain mistakes; the official description above is the record.
